Bug 415371 - RFE: wired 802.1X support
RFE: wired 802.1X support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 03:55 EST by Need Real Name
Modified: 2008-05-02 10:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 10:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-12-07 03:55:46 EST
Given all the code bits are there for WPA Enterprise, I'm a little surprised NM
can't do 802.1X authentication over a wired link.

While the Holy Grail might be to offer a dialog if EAP packets are found on the
wire, maybe it'd be acceptable in the short-term to offer a second "Wired"
option like "Wired (with 802.1X authentication)"?
Comment 1 Need Real Name 2008-03-07 02:13:20 EST
Hi Dan, I see from your latest blog entries
  <http://blogs.gnome.org/dcbw/2008/03/06/free-fast-and-hot/>
and 
  <http://blogs.gnome.org/dcbw/2008/03/06/networkmanager-066-for-fedora-7/>
that this feature is now in NM 0.6 / F7. Is it slated for NM 0.7 / F8 too?
Comment 2 Dan Williams 2008-03-07 07:04:20 EST
Yes, it's slated for 0.7 in F8/F9 too.  Tambet is currently working on it I believe.
Comment 3 Dan Williams 2008-04-10 17:51:01 EDT
Update: the code for this is currently in NetworkManager, but some GUI bits are
missing.
Comment 4 Need Real Name 2008-05-02 04:37:21 EDT
Works for me using 0.7.0-0.9.3.svn3623.fc9. Very nice :)

I do note that when I plug in the wire it leaves the wireless interface
configured up.

1. After 802.1X both interfaces are hooked up to the same (identity-driven) VLAN
2. I have two different IP addresses on the same subnet
3. My routing table shows an entry for the same subnet via each interface

Is this expected behaviour? Do the routing metrics make everything Just Work?

I guess a suitably scary option might allow me to hook both interfaces into a
Linux bridge, but this only works sanely when they're on the same VLAN and if
you're super-careful in avoiding loops. The advantage of this, though, is that
my SSH sessions never break :)

But I digress. Thanks for enabling wired 802.1X :)
Comment 5 Dan Williams 2008-05-02 10:39:11 EDT
Yeah, since 0.7 has multiple active connection support, NM will just switch the
default route to the "best" device.  It will bring up any connection marked
"autoconnect" on any suitable device.

Note You need to log in before you can comment on or make changes to this bug.