This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 415541 - [bn_IN][oowriter] - bn_IN text not visible with "DejaVu LGC Sans Mono" selected
[bn_IN][oowriter] - bn_IN text not visible with "DejaVu LGC Sans Mono" selected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: i18n, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 07:26 EST by Satyabrata Maitra
Modified: 2008-01-11 17:14 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.8-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:14:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2007-12-07 07:26:56 EST
Description of problem:
Bengali text not visible, until lohit fonts not selected.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.3.0-6.6.fc8
openoffice.org-langpack-bn-2.3.0-6.6.fc8
fonts-bengali-2.1.5-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Open any bn_IN content oowriter in bn_IN locale
2. Observe the result
3.
  
Actual results:
Text not visible if not selected lohit fonts

Expected results:
Text should be atleast visible

Additional info:
Screenshots will be attached once soon QE reproduces it, setting up the
environment. For now this bug has been filed depending on the LMs report during
One Test Event.
Comment 1 Caolan McNamara 2007-12-10 07:18:46 EST
It all works fine for me in F8 as far as I can see, so I'm going to need to see
these screenshots and a how to reproduce and possibly the output of fc-list, and
the output of echo $LANG otherwise I'm going to close this as worksforme.
Comment 2 Satyabrata Maitra 2007-12-11 04:13:00 EST
Ok, Let me explain pls. The fine tuned steps are as follows :-

1. Open oowriter in en_US locale
2. Copy and Paste the content of following URL there in oowriter.
   bn.wikipedia.org OR
 
http://i18n.brisbane.redhat.com/~llim/rendering/CJKI%20bold-nornal%20font%20compare
(Follow the bn_IN locale content and paste it in oowriter)
3. Observe the result
4. Comment :- As when oowriter is opened in en_US locale, it takes Liberation
Serif font by default. So the problem will be traced easily if oowriter is
opened in en_US locale. But even if it is opened in bn_IN locale, and after
following the step 2, if the content is selected and the font is changed to
Liberation (serif, sans or mono), the result will be shown as the same as en_US.
I think Liberation font is not able to handle the Indic locale to show. I
checked with Chinese contents, its showing OK.
Comment 3 Caolan McNamara 2007-12-11 05:55:49 EST
Its not as simple as that. e.g. Copying the bn text from the above test case and
Ctrl + Shift + V and paste as unformatted text, this will likely work. Or paste
as  normal, select the text and change the font to "random". 

i.e. "DejaVu LGC Sans Mono" seems to be the problem, somehow either claiming to
support the glyphs or icu is handling it differently for some specific reason
Comment 4 Caolan McNamara 2007-12-11 06:29:38 EST
http://bugs.icu-project.org/trac/ticket/6084
Comment 5 Caolan McNamara 2007-12-11 06:42:01 EST
what the hell, where did "notabug" come from
Comment 6 Caolan McNamara 2007-12-11 08:03:56 EST
Please test the F-8 proposed update package for me at:
http://koji.fedoraproject.org/packages/icu/3.8/4.fc8/
Comment 7 Satyabrata Maitra 2007-12-12 07:11:33 EST
Hi Caolan

I tested this bug with the proposed updated package for libicu and icu, URL
given in above comment. 
This bug is fixed here in this proposed version.
Thanks!

Version of the Component Tested :-
icu-3.8-4.fc8
icu-debuginfo-3.8-4.fc8
libicu-3.8-4.fc8
libicu-devel-3.8-4.fc8
Comment 8 Fedora Update System 2007-12-12 14:53:53 EST
icu-3.8-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update icu'
Comment 9 Satyabrata Maitra 2008-01-07 07:21:28 EST
The same version is already tested and the result is commented on #7. For any
further test, pls inform. I think, this bug can be closed for now. Will do it!
Comment 10 Satyabrata Maitra 2008-01-09 00:54:22 EST
This bug is fixed in the proposed version. Tested. Closing it now. For Complete
Test Report, please have a look on Comment #7 in this bug.
Comment 11 Fedora Update System 2008-01-11 17:14:51 EST
icu-3.8-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.