Bug 415551 - Prelink Corrupts Binaries
Prelink Corrupts Binaries
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 07:34 EST by Chris Spencer
Modified: 2007-12-07 08:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-07 08:48:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Spencer 2007-12-07 07:34:52 EST
Description of problem:
Prelink strips data from some binaries, making them unusable.

Steps to Reproduce:
1. Install Bitpim (http://www.bitpim.org) or Neko (http://www.nekovm.org)
2. Run prelink.
3. Run "bitpim" or "nekotools server". Notice they return an error because data
has been stripped from these binaries.
4. yum uninstall prelink
5. reinstall bitpim or neko
6. Rerun "bitpim" or "nekotools server". Notice they run as expected.
  
Actual results:
Prelink strips data from some binaries.

Expected results:
Prelink should not strip data from any binaries.

Additional info:
Removing prelink from my system fixed the problem. However, determining prelink
to be the culprit was not immediately evident and caused much frustration. If
prelink is not designed to corrupt binaries in this way, then it should be
fixed, or at least not installed by default.
Comment 1 Jakub Jelinek 2007-12-07 08:48:18 EST
If they concatenate ELF binaries (or shared libraries) with arbitrary data after
it, without putting that at least into unallocated sections, then they are
terminally broken.  From a quick check of the bitpim binary in the i386.rpm on
their website that's what they are doing.
You can work around their bugs by adding /etc/prelink.conf.d/bitpim.conf
etc. snippets which will blacklist those binaries, but really the apps should be
fixed not to do this.  Please report it to them and let them fix this.

Note You need to log in before you can comment on or make changes to this bug.