Bug 4158 - /dev/fd0 permissions
/dev/fd0 permissions
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
6.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-22 08:19 EDT by milburn
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-30 17:41:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description milburn 1999-07-22 08:19:13 EDT
I don't think this is a high priority, but it annoys me
so I thought I'd submit it and hopefully it will get
fixed.

/dev/fd0 comes with the following permissions:

brw-------   1 root floppy  2, 0 May  5 1998 /dev/fd0

This causes problems for my users because they can't
use the "mtools" to write to the floppy because they
are not root or in the floppy group.

I know I could just add them to the floppy group or
chmod it to 666, but wouldn't it make more sense just
to have the 'default' permissions be "666" on /dev/fd0?
Comment 1 Jay Turner 1999-07-22 11:06:59 EDT
We try to establish the most secure defaults that we can for a system
and then allow the users to lighten those restrictions, so while in
your case, it would make more sense for the default permissions to be
set to 666, it would not make more sense for an administrator of a
more secure system.  We try to err on the side of safety.
Comment 2 Michael K. Johnson 1999-07-30 17:40:59 EDT
No, this really is a bug...  Should be 660 permissions
Comment 3 Michael K. Johnson 1999-07-30 17:41:59 EDT
Will be fixed in the next release of pam.
In the meantime, you can modify the floppy entry in
/etc/security/console.perms to read
<console> 0660 <floppy>    0660 root

Note You need to log in before you can comment on or make changes to this bug.