Bug 415821 - [hts-5.1-13] info test fails on RHEL 4.6
[hts-5.1-13] info test fails on RHEL 4.6
Status: CLOSED DUPLICATE of bug 390501
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Greg Nichols
Depends On:
  Show dependency treegraph
Reported: 2007-12-07 11:40 EST by Rick Hester
Modified: 2008-07-16 17:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-07 13:31:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rick Hester 2007-12-07 11:40:23 EST
Description of problem:
The info test fails when run on RHEL 4.6.

[root@max2 info]# hts certify --test=info
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
running only test info
running info on
mkdir -p /tmp/hts-info-BrVwgb/mnt/tests/HTS/hts/info
cp -a testinfo.desc runtest.sh info.py Makefile
install -m 0755 runtest.sh /tmp/hts-info-BrVwgb/mnt/tests/HTS/hts/info
make OUTPUTFILE=/var/log/hts/runs/1/info/output.log RUNMODE=normal UDI= DEVICE=
TESTSERVER=unknown run
chmod a+x ./runtest.sh ./info.py
Running ./info.py:
package None is not installed
Error: could not determine kernel RPM name
OS Version RHEL4, kernel rpm None
+ rpm -ql None
Error: files from None were modified
...finished running ./info.py, exit code=1
recovered exit code=1
hts-report-result info FAIL /var/log/hts/runs/1/info/output.log
saveOutput: /var/log/hts/runs/1/info/output.log
Return value was 0

Version-Release number of selected component (if applicable):
[root@max2 info]# uname -a
Linux max2.sapphirev.test 2.6.9-67.EL #1 SMP Wed Nov 7 13:43:35 EST 2007 ia64
ia64 ia64 GNU/Linux

How reproducible:

Steps to Reproduce:
1.install hts-5.1-13 on an 'everything' rhel4.6 install
2.run hts certify --test=info
Actual results:
info test does not run and reports as a failure

Expected results:
info test to run

Additional info:

it appears that there's an incorrect string match in info.py
that is being used to build the kernel rpm name.

If I make this change in info.py, the test runs as expected:

[root@max2 info]# diff info.py info.py.fix
>             self.kernelRPMName = "kernel-2.6.9-67.EL"
Comment 1 Greg Nichols 2007-12-07 13:31:09 EST
Fixed in R14 and beyond.

*** This bug has been marked as a duplicate of 390501 ***
Comment 2 Rick Hester 2007-12-07 15:28:10 EST
I did a search on bugs to see if this had not been reported yet.   It seems
that the duplicate bug 390501 is restricted and I can't see it.

Since this has been fixed in R14, but I don't have R14, may I submit results
that have been acquired using the workaround that I mention in the base

Note You need to log in before you can comment on or make changes to this bug.