Bug 415991 - dirty partition could hang init on boot. seen error: init[1] trap divide error rip:338c0058a4 ...
dirty partition could hang init on boot. seen error: init[1] trap divide erro...
Status: CLOSED DUPLICATE of bug 398281
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 14:54 EST by Luigi Tarenga
Modified: 2007-12-10 14:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 14:57:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first MB of dirty data that make init crash at boot (18.21 KB, application/octet-stream)
2007-12-07 14:56 EST, Luigi Tarenga
no flags Details

  None (edit)
Description Luigi Tarenga 2007-12-07 14:54:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc8 Firefox/2.0.0.10

Description of problem:
i have a pc with 2 identical sata hdd. after reorganizing partitions on
the second driver (/dev/sdb) i had the machine unable to boot.
i found that the content of /dev/sdb2 was creating problem (i found this
by trial&error).
after the reorganization /dev/sdb2 start few sector after and old partition.
at boot (remove "quite" from grub cmd line) i can see:
init[1] trap divide error rip:338c0058a4 rsp:7ffff88a2fa0 error:0
printk: 4821310 messages suppressed.
(and so on forever...)

to fix the problem i can boot from rescue cd and i have 2 option both working:
1) remove the offending partition from disk
2) erasing the content of the partition ( i just overwritten the first MB)

before erasing the content i saved the first MB of /dev/sdb2 
(dd if=/dev/sdb2 of=sdb2.dump count=2048) and i tried to create 
another parition in a new area of the disk, i copied
the first MB and i found the same error at boot but with different rsp offset.
i will attach the dump of the first MB because i think the problem i reproducible.

Version-Release number of selected component (if applicable):
sysvinit-2.86-18

How reproducible:
Always


Steps to Reproduce:
1. create an empy Linux partition (type 83)

2. fill it with the dirty first MB i will attach: 
gunzip sdb2.dump.gz
dd if=sdb2.dump of=/dev/sdXY count=2048

3. reboot the host

Actual Results:
init hang (it seems to restart forever)

Expected Results:
init should be able to boot even if some partition have dirty content

Additional info:
Comment 1 Luigi Tarenga 2007-12-07 14:56:38 EST
Created attachment 281531 [details]
first MB of dirty data that make init crash at boot
Comment 2 Bill Nottingham 2007-12-07 15:57:53 EST
There's nothing in init that reads partitions - this is more likely the kernel
or drivers.
Comment 3 Chuck Ebbert 2007-12-07 16:42:41 EST
Is the e2fsprogs package up-to-date on this system?
Comment 4 Luigi Tarenga 2007-12-07 20:41:21 EST
e2fsprogs-1.40.2-10.fc8 is installed.
kernel version is kernel-2.6.23.8-63.fc8
(i run a system update few hours ago)

fyi: i tried to mount the root with roto=/dev/sda1 and root=LABEL=/12
but in both case i can hit the problem.

the rescue cd does not have problem with the dirty partition and is able
to find and mount automatically my root partition on the first drive.

let me know if you are able to reproduce the bug.
Comment 5 Chuck Ebbert 2007-12-10 13:22:35 EST
(In reply to comment #4)
> e2fsprogs-1.40.2-10.fc8 is installed.
> kernel version is kernel-2.6.23.8-63.fc8
> (i run a system update few hours ago)
> 
> fyi: i tried to mount the root with roto=/dev/sda1 and root=LABEL=/12
> but in both case i can hit the problem.
> 
> the rescue cd does not have problem with the dirty partition and is able
> to find and mount automatically my root partition on the first drive.
> 

Current e2fsprogs is 1.40.2-11 and that should fix the bug.

Comment 6 Luigi Tarenga 2007-12-10 14:00:03 EST
hi,
i just did un update this morning and i have installed the new 
e2fsprogs-1.40.2-11.fc8 package.
i made a test now and i still get the error. What i don't understand is:
after the installation of e2fsprogs the initrd image was not touched
so initrd-2.6.23.8-63.fc8.img is still the one installed by the last kernel
update and if i get it right the error present when init is run and the
actual root (with the e2fsprogs utility) provided by the initrd image.
maybe the e2fsprogs-1.40.2-11.fc8 contain the fix but then i should manually
update the initrd image or wait for the next kernel package update.
can you confirm?
meanwhile i'll try to make some other test.
Comment 7 Chuck Ebbert 2007-12-10 14:12:34 EST
(In reply to comment #6)
> maybe the e2fsprogs-1.40.2-11.fc8 contain the fix but then i should manually
> update the initrd image or wait for the next kernel package update.
> can you confirm?

Yes, that needs to be done too.

There are directions for rebuilding the initrd here:

https://fedoraproject.org/wiki/KernelCommonProblems

Comment 8 Luigi Tarenga 2007-12-10 14:23:59 EST
i just did another test now with the initrd image updated and
it works fine! no more hang at boot.
for me this bug can be closed. thank you very much

Luigi
Comment 9 Chuck Ebbert 2007-12-10 14:57:34 EST

*** This bug has been marked as a duplicate of 398281 ***

Note You need to log in before you can comment on or make changes to this bug.