Bug 416091 - Missing dependency on func
Missing dependency on func
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: func (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 15:57 EST by Steve Milner
Modified: 2014-01-21 18:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 10:25:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated spec and version (2.34 KB, patch)
2007-12-10 09:08 EST, Steve Milner
no flags Details | Diff

  None (edit)
Description Steve Milner 2007-12-07 15:57:06 EST
Description of problem:
Installing func and running 
$ func scrubbed.host call hardware info
func scrubbed.host call hardware info on scrubbed.host:51234 running hardware
info ()
remote exception on scrubbed.host:51234: <Fault 1: 'exceptions.ImportError:No
module named smolt'>
$

Version-Release number of selected component (if applicable):
$ rpm -qa | grep func
func-0.13-3.el5
$

How reproducible:
Every install on EPEL without smolt.

Steps to Reproduce:
1. Install func via EPEL on RHEL5
2. Set it up per instructions found at
https://hosted.fedoraproject.org/projects/func/wiki/InstallAndSetupGuide
3. run func scrubbed.host call hardware info
  
Actual results:
remote exception on scrubbed.host:51234: <Fault 1: 'exceptions.ImportError:No
module named smolt'>

Expected results:
Data to come back.

Additional info:
$ uname -a
Linux scrubbed.host 2.6.18-8.1.15.el5 #1 SMP Thu Oct 4 04:06:15 EDT 2007 i686
i686 i386 GNU/Linux
$ python -V
Python 2.4.3
$

Installing smolt fixes the issue.
Comment 1 Steve Milner 2007-12-10 09:08:15 EST
Created attachment 282801 [details]
Updated spec and version

Added smolt to requires.
Comment 2 Michael DeHaan 2007-12-10 10:24:43 EST
Thanks for the report, though I think this is a feature, not a bug.

The reason for this is Func is intended to run in lots of places, with the
modules only becoming enabled when their prereqs are installed.

Another example is how we have a yum module, but don't require yum.


Note You need to log in before you can comment on or make changes to this bug.