Bug 41631 - usb mouse slowdown (sometimes)
usb mouse slowdown (sometimes)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 12:08 EDT by Carlos Rodrigues
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 22:11:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2001-05-21 12:08:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Sometimes after starting X the mouse seem very slow (low acceleration). 
Reloading the usb modules (or rebooting) seems to fix it, so I don't 
really know if this is a X or kernel problem. Anyway it happens with X 
so...

How reproducible:
Sometimes

Steps to Reproduce:
1. startx
2. move the mouse fast
3.
	

Actual Results:  The mouse sometimes seems to have low acceleration.

Expected Results:  The mouse should move fast always.

Additional info:

I have a usb microsoft intellimouse optical and I'm using usb-uhci.o.
Comment 1 Mike A. Harris 2001-05-21 21:22:04 EDT
Are you using GNOME or KDE?  Check your mouse settings in either one's
control panel.  You can change the mouse acceleration.  If this doesn't help
at all, I believe it would be a kernel problem as X gets USB events from the
kernel.

Arjan, have you heard anything about such USB problems?  I'm USB-less myself..
Comment 2 Arjan van de Ven 2001-05-22 03:51:35 EDT
Pete: did you see this ever before ?
Comment 3 Carlos Rodrigues 2001-05-22 22:00:46 EDT
It doesn't matter the window manager. It happens both with Gnome and KDE as 
well as with just XFree86 without any window manager. And it's apparently 
random, at least I haven't been able to reproduce it.
Comment 4 Pete Zaitcev 2001-05-22 22:11:38 EDT
No, I did not see it before. Never heard of it either.

It is unlikely that something is wrong with X,
but it may be a good idea to do "xset q" before
and after the problem happens.

It would be helpful if the requestor tried to
correlate the problem with USB bus renumeration
by reading "dmesg | tail -50" periodically.

If xset q result does not float, I am willing take the bug,
but I am afraid it will be hard to crack. I need something
reproducible.
Comment 5 Mike A. Harris 2002-03-16 10:33:03 EST
Closing bug since it is unlikely to be an X bug, and there is no way
to debug this without reproduceability or more information.

Note You need to log in before you can comment on or make changes to this bug.