Bug 41634 - RelationSet.pm not found, no index.html or equiv., no INSTALL doc
RelationSet.pm not found, no index.html or equiv., no INSTALL doc
Status: CLOSED DUPLICATE of bug 19497
Product: Red Hat Powertools
Classification: Retired
Component: bugzilla (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
David Lawrence
ACTUAL COMPONENT: bugzilla-2.10-8
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 12:49 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 13:47:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-21 12:49:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
After updating my apache config, figuring out how to create the bugs 
database and finally running some CGI scripts - I get this error message: 
Can't locate RelationSet.pm [...] at globals.pl line 69. Grepping the 
bugzilla files turns up nothing, ditto for searching the CPAN site, ditto 
for `locate Relation`;

How reproducible:
Always

Steps to Reproduce:
1. rpm --install bugzilla-2.10-8
2. Update localconfig
3. Allow Options ExecCGI in /etc/httpd/conf/httpd.conf 
or /bugzilla/.htaccess 
4. Run checksetup.pl
5. lynx http://localhost/bugzilla/query.cgi

Actual Results:  The messages are all similar - here's the second one:

Software error:
[Mon May 21 12:36:13 2001] query.cgi: Can't locate RelationSet.pm in @INC 
(@INC contains: /usr/lib/perl5/5.6.0/i386-
linux /usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-
linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at 
globals.pl line 69. BEGIN failed--compilation aborted at globals.pl line 
69. 
For help, please send mail to the webmaster...




Expected Results:  See: http://bugzilla.redhat.com/bugzilla/query.cgi =8^)


Additional info:

Please send email to sam@azertech.com telling me how to get RelationSet.pm 
so that I can start using bugzilla!

You should also include an INSTALL text with this RPM so that people can 
get started more quickly (or possibly a script that updates localconfig 
and runs checksetup.pl automatically.

Finally, this package needs an index.html file with a few links and some 
explanatory notes.
Comment 1 David Mason 2001-05-21 13:47:25 EDT
Tim - this was filed against bug-buddy, have re-filed. Looking at the source for
bugzilla RelationSet.pm should be included - correct?
Comment 2 Tim Powers 2001-05-21 14:05:37 EDT
Correct, this is fixed in the version of bugzilla in rawhide. 

*** This bug has been marked as a duplicate of 19497 ***
Comment 3 Need Real Name 2001-05-21 18:11:50 EDT
I'm sorry - I can't see #19497.

Thanks! I'll download a rawhide copy!

Thanks again,
Take Care,
Sam.
Comment 4 Need Real Name 2001-05-21 18:42:09 EDT
Sorry to bother you guys again; please let me know if I'm making an obvious 
mistake:

These two files are identical:

ftp://rawhide.redhat.com/redhat/linux/rawhide/powertools/i386/RedHat/RPMS/

The local file "bugzilla-2.10-8.noarch.rpm" already exists.
        Local:        147030 bytes, dated Thu 24 Aug 2000 10:47:45 AM EDT.
        Remote:       147030 bytes, dated Thu 24 Aug 2000 10:47:45 AM EDT.
        (Files are identical, skipped)

The local file was copied from a different rawhide directory and found to be 
identical (diff found no difference,) to the file on the Seawolf Powertools ISO.

Am I looking in the wrong place or did somebody accidentally put the wrong file 
up?

Please let me know,
Thanks,
Take Care,
Sam.
Comment 5 Tim Powers 2001-05-21 22:04:45 EDT
For some reason it wasn't pushed. I rebuilt it ljust now and
it should show up in rawhide the next time it is updated.

Tim

Note You need to log in before you can comment on or make changes to this bug.