Bug 4164 - install exits abnormally
install exits abnormally
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
Depends On:
  Show dependency treegraph
Reported: 1999-07-22 13:45 EDT by rm03447
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-09-08 17:17:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description rm03447 1999-07-22 13:45:55 EDT
If I install Linux using the packages selected by default,
all goes right. But if I change the selections, adding (and
not removing) packages, install exits with this message:

Install exited abnormally - received signal 7

The same thing happens if I upgrade my Linux system.

Maybe this is a consequence of a I/O error happening while
reading the CD-ROM
Comment 1 Jay Turner 1999-07-22 14:09:59 EDT
Is there any particular package selection that leads to this
behavior?  In general, we are not aware of any problems adding
pacakges to the installation, so if you could provide us with a
specific example that causes this behavior we will try to replicate
the situation in the lab.
Comment 2 rm03447 1999-07-31 11:31:59 EDT
For example, if I select the package group KDE, when I install the
system from scratch, I receive the error message.
I have not tried adding individual packages during install, but I
it during upgrade (and it does not function).
Maybe you can find useful to know that I have an old 2X CD-ROM driver
from Sound Blaster (Panasonic) that never had problems with CD-ROMs.
Anyway, if I install the KDE-related packages from GNO-RPM, everything
runs normally.
Also, I remember that a time, when install failed,  I saw also this
message : "VFS - Kernel panic" or something similar.
During upgrade I saw this message too in the installation log screen :
"I/O error while reding sector xxx" referring to the CD-ROM.
The bug can reside in the handling of the I/O errors.
Comment 3 David Lawrence 1999-09-08 17:17:59 EDT
Have you tried different install media. It could be a bad cdrom disc.
Also our installation support people may be able to help better on
this problem. We have not encounterd similar problems in our test lab
so I would suspect media problems.

Note You need to log in before you can comment on or make changes to this bug.