Bug 4165 - kickstart installation problem
kickstart installation problem
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-22 15:02 EDT by pzu
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 16:17:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pzu 1999-07-22 15:02:16 EDT
Contact Information:
pzu@ch.ibm.com
Registration: 48ae02fea44143c7 Red Hat Linux 6.0/Intel

Product:
Red Hat Linux 6.0
Category:
Bugs and other Problems
Summary:
kickstart installation problem
Your Previous Description:
As discussed a little while ago on the phone...

I installed RedHat Linux 6.0 on my system and I am trying to
configure
the kickstart installation. I downloaded the new boot and
supp images
and I use those now. I created the kickstart file ks.cfg and
copied it
to the boot diskette. I inserted the boot diskette and the
installation
CD and started the machine. At the prompt, I entered "linux
ks=floppy"
and pressed enter. The system loaded "initrd.img" and
"vmlinuz", then I
got the following error messages:

- main screen:
Error - mount failed: Invalid argument
- install log (Alt-F3):
* mounting fd0 on /tmp/floppy as ext2
* creating directory /tmp/floppy rc = 0
* calling mount(/tmp/fd0, /tmp/floppy, ext2, -1058209791,
(nil))
- system log (Alt-F4)
<5>RAMDISK: Compressed image found at block 0
<4>VFS: Mounted root (ext2 filesystem).
<7>VFS: Disk change detected on device fd(2,0)
<4>VFS: Cannot find an ext2 filesystem on dev fd(2,0)

All I could do was press "OK" which I did. This brought up
the following
message:

PCMCIA Disk: I failed to mount the floppy. Please insert the
Red Hat
PCMCIA disk, or choose Cancel to pick a different
installation process.

After inserting the PCMCIA disk, the above message was just
redisplayed
whenever I pressed enter. I did use the new boot image as
suggested in
the rh60-general-errata, however, the error was the same. I
tried with a
1.44 and a 2.88 floppy drive attached externally to an IBM
ThinkPad
760CD.

While I could use the RedHat Linux 6.0 "ks.cfg" file
together with the
Redhat Linux 5.2 boot diskette, there are certain features
(e.g. the
auth directive) that do not work under RedHat Linux 5.2.
Also, the
password for the root userid was not properly set (i.e. I
could not
logon after the system was installed).

Please let me know if there is already a solution for this
problem or
until when I can expect there to be one.

Would it be possible to transfer the contents of the
diskette to a different
diskette with an ext2 filesystem? What would be the easiest
way to do that?

Here is an extract from the ks.cfg file I copied to the boot
diskette:

#-----------------------------------------------------------
---------------
# Kickstart file for RedHat 6.0 an IBM ThinkPad 760CD
#-----------------------------------------------------------
---------------
lang en
cdrom
keyboard sg-latin1
zerombr yes
clearpart --all
part / --size 482
part swap --size 32
install
mouse genericps/2 --device psaux --emulthree --noprobe
timezone Europe/Zurich

Thank you for your help
Peter Zuerrer

Peter Z|rrer
e-mail: pzu@ch.ibm.com
Our Previous Response:
At 7/22/99 1:21 PM we wrote -

I'm sorry, but kickstart configuration is an administrative
issue and doesn't fall under the installation support we can
provide. For more information on our support policies, refer
to appendix A of the install guide or
http://charlotte.redhat.com/support/register/support-policy.
html

This may be a defect in kickstart. Bug reports should be
submitted to QA and Development at
http://developer.redhat.com/bugzilla/

I am closing this ticket because this is not a supported
installation issue.

Note You need to log in before you can comment on or make changes to this bug.