Bug 41652 - request: disable gdbm support and CFLAGS
request: disable gdbm support and CFLAGS
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 14:19 EDT by Andreas J. Bathe
Modified: 2007-03-26 23:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 06:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas J. Bathe 2001-05-21 14:19:00 EDT
Description of Problem:
LPRng produces sometimes an interupted system call:
[...] Open_gdbm: cannot lock 'db.XXX' - Interrupted system call


How Reproducible:
Open_gdbm: cannot lock 'db.ps2' - Interrupted system call

The LPRng mailing list suggest to disable the gdbm support. And: Is the
debugging switch really necessary?

I suggest building the LPRng package with the following change:
4c4
< Release: 22
---
> Release: 23
73c73
< CFLAGS="-g" ; export CFLAGS
---
> CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
74a75
>       --disable-gdbm \

Take care
Andreas
Comment 1 Need Real Name 2001-07-18 15:02:23 EDT
On my system this problem shows up once a month when we're trying to print
100-200 pages with invoices. Printing stops after a while. By adding a new
printjob printing resumes. In the log I see a whole buch of "cannot lock 'db.lp'
- Interrupted system call" messages.

BTW. Why do you think disabling gdbm solves the problem?
Comment 2 Andreas J. Bathe 2001-07-19 03:11:20 EDT
As I mentioned it above, I read this advice on the LPRng mailing list and since
I did it our company print- and faxserver which serves 6 printers behaves very
well since May 21th without any problems anymore.

Andreas
Comment 3 Joerg Krause 2001-07-19 09:30:39 EDT
We have the same problem on some productions systems. If there are more than 100 Jobs in the queue LPRng stops
printing fopr that queue. After recompiling LPRng with the --disable-gdbm option everything works fine here.
Comment 4 Yong Chen 2001-08-08 15:46:23 EDT
Please give some instructions for rebuilding the packages.  Where to make those 
changes.  Thanks.
Comment 5 Andreas J. Bathe 2001-08-09 06:11:56 EDT
Change the spec file of LPRng with the diff information in the first comment and
rebuild the binary package with rpm -bb LPRng.spec (or whatever name you use).
Comment 6 Crutcher Dunnavant 2001-08-10 21:22:38 EDT
okay, next version.

Note You need to log in before you can comment on or make changes to this bug.