Bug 416551 - Installation of Fedora 8 i386 DVD on HP nc6000 laptop fails
Installation of Fedora 8 i386 DVD on HP nc6000 laptop fails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 09:16 EST by Jason Curl
Modified: 2009-01-09 00:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:27:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Curl 2007-12-08 09:16:59 EST
Description of problem:
Installation of the Fedora 8 OS on a HP nc6000 (German) laptop fails early in
the process. Similar to bug 386451, except this is i386 and potential
recommendations do not help. Marked as urgent as there is no workarounds present
to install the Operating System.

Version-Release number of selected component (if applicable):
Fedora 8

How reproducible:
100% reproducible

Steps to Reproduce:
1. Insert DVD, wait for boot
2. Choose install method (normal or text, doesn't matter)
3. Skip or test media, doesn't matter
  
Actual results:
Crash, see description

Expected results:
Installation should continue.

Additional info:
Start Fedora 8 DVD install on a Compaq HP nc6000 (German). Media check is fine.
When installing, get the error:

*** glibc detected *** /sbin/loader: munmap_chunk(): invalid pointer: 0x0a29d140

======= Backtrace: =========
[0x81a4083]
[0x805b750]
[0x805c153]
[0x804b207]
[0x8175004]
[0x8048151]

======= Memory map: =======
00110000-00111000 r-xp 00110000 00:00 0 [vdso]
08048000-0828e000 r-xp 00000000 00:01 36 /sbin/loader
0828e000-08299000 rw-p 00245000 00:01 36 /sbin/loader
08299000-082d3000 rw-p 08299000 00:00 0
0a24c000-0a319000 rw-p 0a24c000 00:00 0
b7f85000-b7f88000 rw-p b7f85000 00:00 0
bff38000-bff4d000 rw-p bffea000 00:00 0 [stack]

loader received SIGABORT! Backtrace:
[0x804a030]
[0x110420]
[0x81e7f80]
[0x8182a30]
[0x819930b]
[0x81a4083]
[0x805b750]
[0x805c153]
[0x804b207]
[0x8175004]
[0x8048151]
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystesm...
  /mnt/runtime done
  disabling /dev/loop0
  /proc/bus/usb done
  /proc done
  /dev/pts done
  /sys done
  /tmp/ramfs done
  /mnt/source done
  /selinux done
you may safely reboot your system


When passing options to grub for the installation "nohz=off nolapic" this
doesn't help. Neither does passing "SATA=compatible" on boot helps.

It was interesting that on the first boot, the initial error was a glibc double
free error. This occurred until I first tried the other options. Since then, it
doesn't matter what options are tried, failures occur.

The partition table is as follows:
/dev/hda1 - Windows (25G)
/dev/hda2 - Windows (15G)
/dev/hda3 - Swap (2G)
/dev/hda4 - Extended
/dev/hda5 - /home (8G)
/dev/hda6 - OpenSuse 10.2 (12G)
/dev/hda7 - OpenSuse 10.3 (12G)
/dev/hda8 - Intended for Fedora 8 (12G)
/dev/hda9 - Empty (12.1G)

Needless to say, OpenSuSE 10.2 and 10.3 have been installed without hitches.
Comment 1 Chris Lumens 2007-12-08 18:46:08 EST
Does booting with nopcmcia help?
Comment 2 Jason Curl 2007-12-09 05:31:16 EST
I've changed the severity to "medium" as I have found a workaround in the fedora
forum and have the software installed.

See conversation: http://forums.fedoraforum.org/showthread.php?t=171438

The workaround is to add "acpi=off apm=off pci=noacpi" to the command line when
loading the kernel. This problem also appears to affect HP nx6125.

It is probably worthwhile to add this information to release notes for Fedora 8.
Comment 3 Bryan Christ 2008-03-17 17:04:23 EDT
I have this problem also on the nc6000 but with the workarounds was able to install.
Comment 4 Bryan Christ 2008-03-17 17:59:34 EDT
These settings will remain in grub.conf after install but can safely be removed
afterward.
Comment 5 Bug Zapper 2008-11-26 03:54:23 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-01-09 00:27:37 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.