Bug 416701 - e2tools build failure
e2tools build failure
Status: CLOSED DUPLICATE of bug 349851
Product: Fedora
Classification: Fedora
Component: e2tools (Show other bugs)
alpha Linux
low Severity low
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-08 14:01 EST by Oliver Falk
Modified: 2007-12-08 17:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-08 16:28:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-12-08 14:01:24 EST
Can you please have a look at the folloing build log and give a comment. 


Comment 1 Hans Ulrich Niedermann 2007-12-08 14:39:13 EST
Probably alpha as a pure 64bit platform defines one of the int types slightly

Unfortunately, there seem to be no "%XXd" type format strings where the "XX"
part always works for "unsigned 64 bit integer", so warnings like these may pop up.

Unless you want to patch that line specifically for Alpha, I'd recommend to
remove the -Werror from the %build section.
Comment 2 Oliver Falk 2007-12-08 14:42:06 EST
Well. I should have taken a closer look. Can you %ifarch alpha this in the spec
and commit? Since Alphacore builds from Fedora cvs... Thx!
Comment 3 Hans Ulrich Niedermann 2007-12-08 14:49:49 EST
Could you check first that this really solves the problem? There might be
similar things lurking somewhere in there.
Comment 4 Hans Ulrich Niedermann 2007-12-08 15:42:53 EST
OK, it is in CVS now.
Comment 5 Oliver Falk 2007-12-08 15:53:01 EST
I've added it to the build queue... Will let you know as soon as it finishes.
Comment 6 Hans Ulrich Niedermann 2007-12-08 16:28:21 EST

*** This bug has been marked as a duplicate of 349851 ***

*** This bug has been marked as a duplicate of 349851 ***
Comment 7 Hans Ulrich Niedermann 2007-12-08 17:29:56 EST
OK, this (0.0.16-6) fails on ppc64 as well. More discussion and resolution over
at #349851.

Note You need to log in before you can comment on or make changes to this bug.