Bug 416801 - old F7 pidgin-rhythmbox seems to cause random crashes
old F7 pidgin-rhythmbox seems to cause random crashes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 15:38 EST by J. Randall Owens
Modified: 2007-12-20 04:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 04:35:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pidgin debug stack trace (131.40 KB, text/plain)
2007-12-08 23:50 EST, J. Randall Owens
no flags Details

  None (edit)
Description J. Randall Owens 2007-12-08 15:38:40 EST
Description of problem:
My Pidgin was randomly crashing from time to time, I think usually when sending
or receiving IMs.  I looked at the extras I had installed, and rebuilt the ones
I had my own versions of from F7, but it was still crashing.  Then, I looked at
the single one left that still had .fc7. in the name, which was
pidgin-rhythmbox.  I uninstalled it, tried pidgin while I rebuilt
pidgin-rhythmbox, installed my new pidgin-rhythmbox, and haven't crashed yet, so
I'm hoping this is the one.
It could also be a combination of pidgin-rhythmbox with one of the other
pidgin-related RPMs I have installed, so you/we might want to try various
combinations.
I haven't even actually used pidgin-rhythmbox in a few months now, and the
crashes happened anyway.  I do, however, still have it enabled in my plugins
selection.

Version-Release number of selected component (if applicable):
pidgin-rhythmbox-2.0-1.fc7

pidgin-perl-2.2.2-1.fc8
pidgin-encryption-3.0-1.f8.gp
pidgin-otr-3.1.0-2.fc8
pidgin-knotify-0.1-5.fc8
pidgin-libnotify-0.13-2.fc8
pidgin-guifications-2.14-0.f8.gp
pidgin-plugin_pack-2.2.0-0.f8.gp

pidgin-2.2.2-1.fc8
pidgin-devel-2.2.2-1.fc8

libpurple-2.2.2-1.fc8
libpurple-devel-2.2.2-1.fc8
libpurple-perl-2.2.2-1.fc8
libpurple-tcl-2.2.2-1.fc8


How reproducible:
Install, run, and wait.

Steps to Reproduce:
1. Install pidgin with pidgin-rhythmbox-2.0-1.fc7.i386, at least
2. Start Pidgin
3. Wait a few hours, possibly a day or two; might help if you have IM activity
  
Actual results:
Pidgin crashes

Expected results:
Pidgin keeps running smoothly

Additional info:
The only thing I changed for my rebuilt pidgin-rhythmbox was the release number.
 Aside, of course, from the libraries it's built against.  So the fix should be
simple enough; technically, you shouldn't even have to change the release
number, as long as it sucks in the new distribution info in the release field.
I haven't run it with a debug yet; if needed, I have installed the
pidgin-debuginfo already, and could provide a dump, with a minimum of pointers.
Comment 1 J. Randall Owens 2007-12-08 15:42:13 EST
I guess I spoke too soon; of course, after running nicely with my new
pidgin-rhythmbox installed for 12 hours or so, pidgin crashed about a minute
after I submitted this.  Feel free to reassign it to general pidgin, and I'll
get those debuginfo RPMs installed.
Comment 2 J. Randall Owens 2007-12-08 19:31:09 EST
Oh, a note on the list of packages above, the ones ending in .gp are the ones
I've (re)built here.

Meanwhile, I'm running Pidgin in gdb, waiting for it to crash again.  I've
installed debuginfo for: pidgin, pidgin-encryption, pidgin-guifications,
pidgin-knotify, pidgin-libnotify, pidgin-otr, pidgin-rhythmbox,
purple-plugin_pack, and rhythmbox.  Are there other significant library
dependencies that might be worth installing to capture more detail in the backtrace?
Comment 3 J. Randall Owens 2007-12-08 23:50:48 EST
Created attachment 282181 [details]
pidgin debug stack trace

This stack trace has lots of '??' in it.  While I know very little about
reading traces, I think it looks like it might be helpful to install debuginfo
for some of the audio, like pulse and gstreamer?
Comment 4 Michel Alexandre Salim 2007-12-18 23:22:10 EST
Sorry for the late response, was busy with exams and traveling. Do you have
Bonjour enabled by any chance? There's a known problem with older Avahi
libraries, so if you have that enabled I might have to open a bug against the F7
avahi.

Comment 5 J. Randall Owens 2007-12-19 00:53:37 EST
I can no longer reproduce this bug.  I've gotten my audio system straightened
out somewhat since I reported this, getting the new PulseAudio business going
(which, probably purely coincidentally, is by the same guy who does Avahi, isn't
it?).  I have had Avahi installed all along, for what it's worth.

One way or another, Pidgin is no longer crashing for me.  I'd be willing to bet
that whatever it was, would never have happened in a clean install.  So it would
probably be very hard to reproduce.
Comment 6 Michel Alexandre Salim 2007-12-20 04:35:43 EST
OK. Will close this now, it can be reopened if anyone else can reproduce this.
Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.