Bug 416861 - texlive-texmf has texdoctk.dat database which does not agree with reality
texlive-texmf has texdoctk.dat database which does not agree with reality
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive-texmf (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 16:21 EST by Michal Jaegermann
Modified: 2013-07-02 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 10:08:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a list of files not found by a simple check (2.25 KB, text/plain)
2007-12-08 16:21 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-12-08 16:21:57 EST
Description of problem:

With perl-Tk installed and assuming that texdoctk started (see below)
various documents cannot be found.  It turns out that texdoctk
is using /usr/share/texmf/texdoctk/texdoctk.dat (and optionally
also $TEXMFLOCAL/texdoctk/texdoctk-local.dat and
$TEXMFHOME/texdoctk/texdoctk-pers.dat) but supplied texdoctk.dat
is obsolete.  It includes entries for files like
fontinstallationguide.pdf, dtxtut.pdf, ... not to be found anywhere
on the disk.  OTOH files which are present, say intro98.pdf
from fontinst documentation, and not listed.

All of that assuming that texdoctk can be even started. Bug 210718
is still there and it seems that it is getting worse over time.
I can still start that on a local display of my system, although
even that is not assured anymore, but touching "Search" or "Settings"
looks like a guaranteed recipe for an instant segfault.

It also looks like that current texdoctk ignores private configuration
in an existing ~/.texdocrc; but it is hard to be sure what is really
happening due to problems mentioned in the previous paragraph.

A quick automated check seems to indicate that the following referenced
in texdoctk.dat files are missing.  Results may be not entirely correct
or complete but mostly should be ok.  Some files may show up after
an installation of additional packages.

Version-Release number of selected component (if applicable):
texlive-texmf-2007-2.fc9

How reproducible:
always
Comment 1 Michal Jaegermann 2007-12-08 16:21:57 EST
Created attachment 282121 [details]
a list of files not found by a simple check
Comment 2 Jindrich Novy 2007-12-09 04:19:00 EST
$ texdoctk
NOTE: Button colours not set in /usr/share/texmf/texdoctk/texdocrc.defaults;
using defaults.
Segmentation fault

... seems that it really needs fixing ...
Comment 3 Jindrich Novy 2007-12-09 04:50:20 EST
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496263824 (LWP 24522)]
0x0000003285e16c7a in FcCompare (pat=0xcd8050, fnt=0x2aaaafe700c0,
value=0xd06c40, result=0x7fffada3baf8) at fcmatch.c:392
392         while (i1 < pat->num && i2 < fnt->num)
(gdb) bt
#0  0x0000003285e16c7a in FcCompare (pat=0xcd8050, fnt=0x2aaaafe700c0,
value=0xd06c40, result=0x7fffada3baf8) at fcmatch.c:392
#1  0x0000003285e170c4 in IA__FcFontSetSort (config=<value optimized out>,
sets=<value optimized out>, nsets=1, p=0xcd8050, trim=1, csp=0x7fffada3bae0,
result=0x7fffada3baf8) at fcmatch.c:708
#2  0x0000003285e175d6 in IA__FcFontSort (config=0xcd8050, p=0xcd8050, trim=1,
csp=0x7fffada3bae0, result=0x7fffada3baf8) at fcmatch.c:836
#3  0x00002aaaafc14ca2 in ?? () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#4  0x00002aaaafc150f6 in TkpGetFontFromAttributes () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#5  0x00002aaaafbd8379 in Tk_AllocFontFromObj () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#6  0x00002aaaafc20230 in ?? () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#7  0x00002aaaafc206bb in Tk_InitOptions () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#8  0x00002aaaafbcf9b3 in ?? () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#9  0x00002aaaafbb0bbb in Call_Tk () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#10 0x00002aaaafbb1439 in XSTkCommand () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#11 0x00002aaaafbb156f in ?? () from
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Tk/Tk.so
#12 0x00000039cae90866 in Perl_pp_entersub () from
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/libperl.so
#13 0x00000039cae8a10e in Perl_runops_standard () from
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/libperl.so
#14 0x00000039cae37ddc in perl_run () from
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/libperl.so
#15 0x00000000004017cc in main ()

hmmm...
Comment 4 Michal Jaegermann 2007-12-09 14:48:56 EST
> hmmm...

You are hitting precisely bug 210718 (reported over a year ago).
Quite a bit of information there.

I would love to know what comments in upstream NOTOURBUG claiming
https://bugs.freedesktop.org/show_bug.cgi?id=8665
https://bugs.freedesktop.org/show_bug.cgi?id=8791
are trying to say but I failed to get anything specific/informative.

BTW - I strongly suspect that bug 210718 is also an underlying
cause of bug 375131 which kills xfs if you will look at it wrong
way.  Fun, eh?
Comment 5 Michal Jaegermann 2008-01-03 17:48:55 EST
It looks like that an update to perl-Tk-804.028-1 (see bug 210718)
brings a long awaited fix to issues noted in comment 2 and comment 3.
Comment 6 Jindrich Novy 2008-01-09 10:08:38 EST
Yes, texdoctk now works as expected, closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.