Bug 416871 - pstoraster needs modification for gs-8.61
pstoraster needs modification for gs-8.61
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-12-08 16:52 EST by Sammy
Modified: 2008-01-27 02:18 EST (History)
0 users

See Also:
Fixed In Version: 1.3.5-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 02:18:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2007-12-08 16:52:42 EST
There is a problem with some files with so build and stdin redirection under
ghostscript 8.61. This is related to bugzilla bug #416321 and resolution
is suggested in ghostscript bugzilla:

http://bugs.ghostscript.com/show_bug.cgi?id=689577

The change needed seems to be:

If your printer uses a CUPS raster driver, the /usr/lib/cups/filter/pstoraster
needs to be patched. Replace the line

ifile="-"

by

ifile="-_"
Comment 1 Sammy 2007-12-09 11:34:48 EST
A patch for this was committed to ghostscript trunk that is submitted to
bug #416321. However, the above changes may still help and future problems
with the same issue. 
Comment 2 Sammy 2007-12-10 09:19:19 EST
Ghostscript people are recommending to make the above change because it
is more "efficient" piping and would avoid future changes.
Comment 3 Fedora Update System 2008-01-06 20:26:52 EST
cups-1.3.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'
Comment 4 Fedora Update System 2008-01-11 17:07:35 EST
cups-1.3.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'
Comment 5 Fedora Update System 2008-01-22 10:31:17 EST
cups-1.3.5-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'
Comment 6 Tim Waugh 2008-01-23 08:02:43 EST
Fix confirmed.
Comment 7 Fedora Update System 2008-01-27 02:18:37 EST
cups-1.3.5-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.