Bug 416911 - gcj is broken since -26
gcj is broken since -26
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
8
alpha Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 18:05 EST by Oliver Falk
Modified: 2008-08-13 05:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 05:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-12-08 18:05:33 EST
Since Release 4.1.2-26, gcj doesn't work any more on alpha. -23 works fine. -24,
-25 I haven't tried (I don't have them from alpha).

However, the failures that occure with -26 and later:
http://buildsys.zero42.at/koji/getfile?taskID=64660&name=build.log

And yes, I've also tried the latest release (-35).
Comment 1 Jakub Jelinek 2007-12-10 07:52:08 EST
There were really no changes that could be relevant between -23 and -26, so very
likely it is caused by some other package which changed too.
Anyway, I don't expect to have any time to look at this in the coming months,
so either you need to debug this yourself, or e.g. try to reproduce with
gcc 4.3.0 and if reproducible, report upstream, etc.
Comment 2 Oliver Falk 2007-12-10 08:06:37 EST
OK. I'll rebuild my working -23 under current buildroot and check if it the new
result does have the same problem. If not, it's gcc's fault :-)

I'm also rebuilding gcc-4.2.2 from tarball at the moment to see if the problem
is the same there.
Comment 3 Oliver Falk 2007-12-10 08:08:36 EST
Jakub, is somebody else, except you, able to check that?

Note You need to log in before you can comment on or make changes to this bug.