Bug 41693 - setgid (mail) for procmail shuld be back
Summary: setgid (mail) for procmail shuld be back
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procmail
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-21 20:54 UTC by Łukasz Trąbiński
Modified: 2007-04-18 16:33 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-05-21 20:54:37 UTC


Attachments (Terms of Use)

Description Łukasz Trąbiński 2001-05-21 20:54:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.5-pre3 i586)

Description of problem:
Setgid flag to /usr/bin/procmail should be back.

How reproducible:
Always

Steps to Reproduce:
1. Install procmail from RH 7.1
2. Install postfix from RH 7.1 powertools (instead sendmail)
3. Try to send mail to new created user (which one has not own mailbox
in /var/spool/mail/$user)
	

Actual Results:  As You know, postfix is running as user mail (not root)

<test@hq.nawigator.pl>: can't create user output file. Command output:
    procmail: Couldn't create "/var/spool/mail/test" procmail: Lock failure
on "/var/spool/mail/test.lock" procmail: Error while writing to
"/var/spool/mail/test"

/var/spool/mail/test didn't exisit before delivered this mail


Additional info:

To fix this problem chmod g+s /usr/bin/procmail. 

ps
Sorry for my borken english. :(

Comment 1 Trond Eivind Glomsrxd 2001-05-21 21:03:07 UTC
The procmail code isn't auditable, the setgid flag is not going back on: We
don't trust it.



Comment 2 Trond Eivind Glomsrxd 2001-06-04 03:57:51 UTC
*** Bug 43365 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.