Bug 41694 - Screen corruption with SIS 630 at 800x600 and over
Screen corruption with SIS 630 at 800x600 and over
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 17:01 EDT by Fernando Carello
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-20 22:37:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config for 4.0.3, SIS630 chipset (2.25 KB, text/plain)
2001-05-22 04:42 EDT, Fernando Carello
no flags Details
Startup log for X 4.0.3, chipset SIS630, resolution 1024x768 (21.95 KB, text/plain)
2001-05-22 04:44 EDT, Fernando Carello
no flags Details

  None (edit)
Description Fernando Carello 2001-05-21 17:01:57 EDT
Description of Problem:
With XFree86 4.0.3 and a SIS630 graphic chip, the graphic screen is blurry and flickers at any resolution over 640x480, no matter the color depth and refresh rate.
Tried many many modelines and all the chipset-specific options within XF86Config, the problem is always there and identical all over.


How Reproducible:
Every time.

Steps to Reproduce:
1.Simply start up X at a resolution above 640x480 (but it's a lot more evident at 1024x768 than at 800x600).

Actual Results:
The whole screen looks blurry and flickers. Seems like a red "ghost image" is created, shifted by 1 pixel on the left of the "right" screen content.

Expected Results:


Additional Information:
The XFree86 log reports nothing strange.
My hardware is a MITAC 7521 notebook with a SIS630 integrated chipset, the display is a 14 LCD TFT.
Tried with another identical machine, all is the same.
	
Will send XFree86.log and XF86Config on request.
Comment 1 Mike A. Harris 2001-05-21 21:24:37 EDT
Yes, please attach the log and config using the fileattachment link below.
No compressed files please.
Comment 2 Fernando Carello 2001-05-22 04:42:35 EDT
Created attachment 19271 [details]
XF86Config for 4.0.3, SIS630 chipset
Comment 3 Fernando Carello 2001-05-22 04:44:51 EDT
Created attachment 19272 [details]
Startup log for X 4.0.3, chipset SIS630, resolution 1024x768
Comment 4 Mike A. Harris 2002-05-20 22:37:36 EDT
Does this problem still exist in Red Hat Linux 7.3?
Comment 5 Mike A. Harris 2002-05-30 02:27:11 EDT
Closing assuming it works in the latest release due to lack of feedback.

Note You need to log in before you can comment on or make changes to this bug.