Bug 417031 - modemlights defaults are unreasonable
modemlights defaults are unreasonable
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 472316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-09 00:18 EST by Andre Robatino
Modified: 2008-12-08 11:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 23:19:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2007-12-09 00:18:08 EST
Description of problem:
  The modemlights defaults in F8 are mostly unreasonable, especially the default
colors which are all black, making them unreadable.  Some of the checkboxes are
also set to unreasonable values.  For anyone who wants the default values from
FC6, here they are:

General tab:
        Display:
                Update every 5 seconds
                Show connect time and throughput (checked)
                Blink connection status when connecting (unchecked)
        Connections:
                Connection command: /sbin/ifup ppp0 (not "pppon" which doesn't work)
                Disconnection command: /sbin/ifdown ppp0 (not "pppoff" which
doesn't work)
                Confirm connection (checked)
Colors tab:
        Receive Data:
                Foreground: #FF0000        Background: #4D0000
        Send Data:
                Foreground: #00FF00        Background: #004D00
        Connection Status:
                Connected: #00FF00        Disconnected: #004D00       
Connecting: #FEF06B
        Text:
                Foreground: #00FF00        Background: #000000        Outline:
#004D00
Advanced tab:
        Verify owner of lock file (checked)
        Use ISDN (unchecked)

Version-Release number of selected component (if applicable):
gnome-applets-2.20.0-8.fc8

How reproducible:
always
Comment 1 Andre Robatino 2008-05-14 15:10:01 EDT
Still exists in F9 with gnome-applets-2.22.1-2.fc9.i386, bumping to F9. 
Presumably it still exists in F8, which most people are still using.  Is there
an easy way to indicate that a bug applies to multiple versions, or should I
copy and paste the whole body of the bug report to make separate bug reports for
each version?  Or should it be assigned to rawhide?
Comment 2 David Woodhouse 2008-11-21 04:06:29 EST
This happens because the %post script doesn't bother to install the modemlights defaults, as it does for all the other applets. Running something like this fixes it for me:

GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` gconftool-2 --makefile-install-rule /etc/gconf/schemas/modemlights.schemas

Bug seems to persist in F10.
Comment 3 David Woodhouse 2008-11-21 04:06:49 EST
*** Bug 472316 has been marked as a duplicate of this bug. ***
Comment 4 Ray Strode [halfline] 2008-11-21 09:10:29 EST
I think what happened here is at one point we stopped building the applet, but then brought it back (see bug 301601), but we forgot about the schemas when we brought it back.
Comment 5 David Woodhouse 2008-11-21 09:13:36 EST
Oops. That'll be my fault then; sorry.
Comment 6 Ray Strode [halfline] 2008-11-21 09:14:02 EST
fixed, marking MODIFIED for a future update
Comment 7 Fedora Update System 2008-11-21 10:29:38 EST
gnome-applets-2.24.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnome-applets-2.24.1-2.fc10
Comment 8 Fedora Update System 2008-11-22 11:45:58 EST
gnome-applets-2.24.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-applets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-9913
Comment 9 Fedora Update System 2008-11-25 01:49:49 EST
gnome-applets-2.24.2-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnome-applets-2.24.2-2.fc10
Comment 10 Fedora Update System 2008-11-26 01:15:52 EST
gnome-applets-2.24.2-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-applets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-10271
Comment 11 Fedora Update System 2008-12-06 23:19:47 EST
gnome-applets-2.24.2-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Andre Robatino 2008-12-07 02:49:59 EST
Verified that all the default settings now are the same as the ones I posted above for FC6, except for the text background color which seems to randomly change.  If I go into the modemlights preferences to check what the text background color is, then close the preferences, then open and check again, the last two characters have randomly changed, for example

#7F0084
#7F0035
#7F00B4
.
.
.

What's up with that?  Is it supposed to be random?
Comment 13 Andre Robatino 2008-12-07 03:01:18 EST
If I explicitly set the text background color (by clicking "OK" instead of "Cancel" in the "Pick a Color" window), then it seems to stick.  However, if I remove the modemlights applet from the panel, then add it again, then check the text background color, it again has a (somewhat) random value - I always see the first 4 characters as 7F00, with the last two characters random.
Comment 14 Ray Strode [halfline] 2008-12-08 11:24:42 EST
Probably some memory corruption bug.  should be filed as a separate issue.
Comment 15 Andre Robatino 2008-12-08 11:29:02 EST
Can you reproduce it?  I have no idea which component to file this under.
Comment 16 Ray Strode [halfline] 2008-12-08 11:37:21 EST
gnome-applets.  I haven't tried to reproduce it, but I'll clone the bug for you.
Comment 17 Ray Strode [halfline] 2008-12-08 11:40:20 EST
Filed as bug 475238

Note You need to log in before you can comment on or make changes to this bug.