Bug 417201 - unresolved deps from bodhi-server
unresolved deps from bodhi-server
Status: CLOSED WORKSFORME
Product: Fedora EPEL
Classification: Fedora
Component: bodhi (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks: EPEL5-BrokenDeps
  Show dependency treegraph
 
Reported: 2007-12-09 08:23 EST by Thorsten Leemhuis
Modified: 2016-09-19 22:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 21:48:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2007-12-09 08:23:45 EST
Not all deps from bodhi-server are in EL5 and EPEL5:

package: bodhi-server - 0.4.4-1.el5.noarch from epel5-testing
   unresolved deps: 
      yum-utils >= 0:1.1.7
      mash

Note that yum-utils 1.0.4 is part of RHEL since 5.1; I'd say it's unlikely that
1.1.7 makes it into it in the near future

Maybe just ship bodhi in EPEL without the server bits?
Comment 1 Tim Lauridsen 2007-12-10 02:20:26 EST
I far as i remember so i bodhi user a recent added command line option to
repoquery, i will look into backport it into yum-utils 1.0.x and make a 1.0.5
release, so can bodhi depend on yum-utils-1.0.5 in EPEL5.

Comment 2 Thorsten Leemhuis 2007-12-10 02:40:35 EST
(In reply to comment #1)
> I far as i remember so i bodhi user a recent added command line option to
> repoquery, i will look into backport it into yum-utils 1.0.x and make a 1.0.5
> release, so can bodhi depend on yum-utils-1.0.5 in EPEL5.

thx tim -- but actually the situation is a bit more complicated: yum-utils will
be dropped from EPEL5 soon, as it's now in RHEL since 5.1 and we don#t want to
replace it in EPEL.

So we'd need to get the patch (once one exists) into RHEL, which I suppose is
way more complicated and likely something that will take a while.
Comment 3 Tim Lauridsen 2007-12-11 04:13:40 EST
(In reply to comment #2)

> thx tim -- but actually the situation is a bit more complicated: yum-utils will
> be dropped from EPEL5 soon, as it's now in RHEL since 5.1 and we don#t want to
> replace it in EPEL.
> 
> So we'd need to get the patch (once one exists) into RHEL, which I suppose is
> way more complicated and likely something that will take a while.

I had forgot about that

Luke: how important is the 'repoquery --repofrompath=repo,path' for the bodhi
operation, can we live without it ??.

Some solutions:

1. distribute a special repoquery with bodhi ( in /usr/share/bodhi), this will
remove the yum-utils dependency.

2. remove bodhi from EPEL5, this will not be a good choice. It don't think it
make sense to remove the bodhi server parts only, it is the server parts there
is most interesting on a EL system.
Comment 4 Luke Macken 2007-12-11 08:05:55 EST
(In reply to comment #3)
> Luke: how important is the 'repoquery --repofrompath=repo,path' for the bodhi
> operation, can we live without it ??.

The --repofrompath is used during the updateinfo.xml.gz generation to get the
rpm checksums.  However, there is currently a ticket open requesting that we
remove them, as they don't seem to be very useful, and it's duplicate
information in the repodata.

   https://hosted.fedoraproject.org/projects/fedora-infrastructure/ticket/262

So, I'd be happy to remove this strict dependency from bodhi by no longer
fetching the checksums.  This will also make pushing a lot faster :)
Comment 5 Luke Macken 2008-01-29 14:36:29 EST
Waiting for python-elixir to grow an EL-5 branch.  This bug will be resolved soon.
Comment 6 Luke Macken 2008-05-12 21:48:10 EDT
I've been using EL-5 bodhi for a while now, with no issues.  Closing...

Note You need to log in before you can comment on or make changes to this bug.