Bug 417221 - php-eaccelerator/php-pecl-memcache: unresolved deps like "0:%{php_zend_api}"
php-eaccelerator/php-pecl-memcache: unresolved deps like "0:%{php_zend_api}"
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: php-eaccelerator (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks: EPEL5-BrokenDeps
  Show dependency treegraph
 
Reported: 2007-12-09 08:44 EST by Thorsten Leemhuis
Modified: 2008-02-03 06:11 EST (History)
0 users

See Also:
Fixed In Version: 0.9.5.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 06:11:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2007-12-09 08:44:44 EST
Description of problem:

From repoclosure:

> package: php-eaccelerator - 1:0.9.5.2-1.el5.x86_64 from epel5-testing
>   unresolved deps: 
>      php(zend-abi) = 0:%{php_zend_api}
>      php(api) = 0:%{php_core_api}
> package: php-pecl-memcache - 2.1.2-1.el5.x86_64 from epel5-testing
>   unresolved deps: 
>      php-api = 0:%{php_apiver}

Looks to me like you use the virtual php provides which are not provided by the
php package from RHEL
Comment 1 Matthias Saou 2007-12-17 16:05:48 EST
Indeed... I tested on EL, but I forgot it was against some custom PHP packages
of mine, which are updated and "fixed" req/prov wise. I'll fix this ASAP. I
haven't received any "broken deps" nag emails for this AFAIR, though :-/
Comment 2 Matthias Saou 2007-12-17 16:43:18 EST
I've added some ugly %if/%endif sections to get stock EL4 and EL5 PHP
requirements right. No other alternatives AFAICS, too bad...
Comment 3 Matthias Saou 2008-02-03 06:11:04 EST
Closing, since the fixed packages have been in EPEL for a while now.

Note You need to log in before you can comment on or make changes to this bug.