Bug 417241 - broken fonts after upgrading to xorg-x11-drv-ati-6.7.196-4.fc8
broken fonts after upgrading to xorg-x11-drv-ati-6.7.196-4.fc8
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-09 09:59 EST by Satish Balay
Modified: 2008-05-09 01:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-09 01:23:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/X11/xorg.conf (573 bytes, text/plain)
2007-12-12 12:43 EST, Satish Balay
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.7.196-4.fc8 [with xorg.conf] (49.77 KB, text/plain)
2007-12-12 12:45 EST, Satish Balay
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.7.196-4.fc8 [without xorg.conf] (53.29 KB, text/plain)
2007-12-12 12:46 EST, Satish Balay
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.7.196-1.fc8 [with xorg.conf] (47.00 KB, text/plain)
2007-12-12 12:48 EST, Satish Balay
no flags Details
Xorg.0.log, with xorg.conf (50.84 KB, text/plain)
2007-12-12 14:23 EST, James Ralston
no flags Details
Xorg.0.log, without xorg.conf (51.87 KB, text/plain)
2007-12-12 14:24 EST, James Ralston
no flags Details
screenshot of fonts (336.23 KB, image/png)
2007-12-15 14:01 EST, Satish Balay
no flags Details

  None (edit)
Description Satish Balay 2007-12-09 09:59:08 EST
Description of problem:
All fonts [in gnome-terminal, gnome-desktop, firefox etc..] were broken. They
had some extra dots showing at the end, or below the regular text.

Version-Release number of selected component (if applicable):

[This package is currently in Fedora8 updates-testing repository]

How reproducible:

Tried only once

Steps to Reproduce:
1. yum --enablerepo=updates-testing update
2. reboot
Actual results:

Broken fonts everywhere.

Expected results:

No broken fonts

Additional info:
Reverting to older version [and rebooting] appears to fix the problem.
rpm -Uvh --oldpackage xorg-x11-drv-ati-6.7.196-1.fc8.i386.rpm

The hardware is a Thinkpad T40 with:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 [Mobility
FireGL 9000] (rev 02)

[Perhaps there is no relation here, but I'm listing the other packages that got
installed together - when the problem appeared]
Dec 08 16:18:39 Updated: coreutils - 6.9-12.fc8.i386
Dec 08 16:18:41 Updated: krb5-libs - 1.6.2-11.fc8.i386
Dec 08 16:18:50 Updated: gtk2 - 2.12.3-1.fc8.i386
Dec 08 16:18:50 Updated: libsepol - 2.0.15-1.fc8.i386
Dec 08 16:18:51 Updated: libsemanage - 2.0.12-2.fc8.i386
Dec 08 16:18:53 Updated: bind-libs - 32:9.5.0-19.b1.fc8.i386
Dec 08 16:18:54 Updated: libxcb - 1.0-4.fc8.i386
Dec 08 16:18:57 Updated: hsqldb - 1:
Dec 08 16:19:40 Updated: openoffice.org-core - 1:2.3.0-6.7.fc8.i386
Dec 08 16:19:47 Updated: util-linux-ng - 2.13-3.1.fc8.i386
Dec 08 16:20:24 Updated: policycoreutils - 2.0.32-2.fc8.i386
Dec 08 16:20:25 Updated: wpa_supplicant - 1:0.5.7-19.fc8.i386
Dec 08 16:20:26 Updated: pciutils - 2.2.9-1.fc8.i386
Dec 08 16:20:30 Updated: openoffice.org-calc - 1:2.3.0-6.7.fc8.i386
Dec 08 16:20:33 Updated: pilot-link - 2:0.12.2-10.fc8.i386
Dec 08 16:20:34 Updated: libshout - 2.2.2-2.fc8.i386
Dec 08 16:20:34 Installed: paps-libs - 0.6.8-1.fc8.i386
Dec 08 16:20:35 Updated: paps - 0.6.8-1.fc8.i386
Dec 08 16:20:37 Updated: openoffice.org-writer - 1:2.3.0-6.7.fc8.i386
Dec 08 16:20:40 Updated: openoffice.org-impress - 1:2.3.0-6.7.fc8.i386
Dec 08 16:20:42 Updated: openoffice.org-draw - 1:2.3.0-6.7.fc8.i386
Dec 08 16:20:42 Updated: openoffice.org-graphicfilter - 1:2.3.0-6.7.fc8.i386
Dec 08 16:20:44 Updated: openoffice.org-math - 1:2.3.0-6.7.fc8.i386
Dec 08 16:20:45 Updated: bind-utils - 32:9.5.0-19.b1.fc8.i386
Dec 08 16:20:46 Updated: krb5-workstation - 1.6.2-11.fc8.i386
Dec 08 16:20:47 Updated: vixie-cron - 4:4.2-6.fc8.i386
Dec 08 16:20:48 Updated: xorg-x11-drv-ati - 6.7.196-4.fc8.i386
Dec 08 16:20:49 Updated: at - 3.1.10-19.fc8.i386
Dec 08 16:20:50 Updated: psmisc - 22.6-1.fc8.i386
Dec 08 16:20:51 Updated: yum - 3.2.8-2.fc8.noarch
Dec 08 16:20:56 Updated: selinux-policy - 3.0.8-64.fc8.noarch
Dec 08 16:21:17 Updated: selinux-policy-devel - 3.0.8-64.fc8.noarch
Dec 08 16:21:20 Updated: system-config-network-tui - 1.4.7-1.fc8.noarch
Dec 08 16:21:22 Updated: system-config-network - 1.4.7-1.fc8.noarch
Dec 08 16:21:23 Updated: policycoreutils-gui - 2.0.32-2.fc8.i386
Dec 08 16:22:21 Updated: selinux-policy-targeted - 3.0.8-64.fc8.noarch
Dec 08 16:22:22 Updated: yum-utils - 1.1.9-1.fc8.noarch
Dec 08 16:22:24 Updated: pirut - 1.3.28-1.fc8.noarch
Dec 08 16:22:26 Updated: yum-updatesd - 1:0.8-2.fc8.noarch
Dec 08 16:22:26 Updated: yum-changelog - 1.1.9-1.fc8.noarch
Dec 08 16:22:30 Updated: openoffice.org-langpack-en - 1:2.3.0-6.7.fc8.i386
Dec 08 16:22:30 Updated: openoffice.org-xsltfilter - 1:2.3.0-6.7.fc8.i386
Dec 08 16:22:32 Updated: libxcb-devel - 1.0-4.fc8.i386
Dec 08 16:22:40 Updated: seamonkey - 1.1.7-1.fc8.i386
Dec 08 16:22:43 Updated: tzdata - 2007j-1.fc8.noarch
Dec 08 16:22:45 Updated: tzdata-java - 2007j-1.fc8.noarch
Dec 08 16:22:47 Updated: NetworkManager - 1:0.7.0-0.6.6.svn3138.fc8.i386
Dec 08 16:22:48 Updated: NetworkManager-glib - 1:0.7.0-0.6.6.svn3138.fc8.i386
Dec 08 16:22:51 Updated: NetworkManager-gnome - 1:0.7.0-0.6.6.svn3138.fc8.i386
Comment 1 Michal Vojan 2007-12-11 18:46:20 EST
I had the same problem until I've reverted back to older version 
Comment 2 James Ralston 2007-12-11 23:27:17 EST
I'm seeing broken/distorted fonts as well.  I have a:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 [Mobility
FireGL 9000] (rev 01)

This only seems to affect fontconfig fonts; old-style (server side) fonts are
not broken.  (E.g., Firefox looks like crap, but Emacs is fine.)

I haven't tried reverting xorg-x11-drv-ati to the "updates" version, but based
on the other comments, I fully expect that will avoid the problem.

I can supply more information and/or screenshots if needed...
Comment 3 Matěj Cepl 2007-12-12 07:49:10 EST
Reporter, thanks for the bug report.  We have reviewed the information you have
provided above, and there is some additional information we require that will be
helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Satish Balay 2007-12-12 12:43:35 EST
Created attachment 285931 [details]
Comment 5 Satish Balay 2007-12-12 12:45:30 EST
Created attachment 285941 [details]
Xorg.0.log with xorg-x11-drv-ati-6.7.196-4.fc8 [with xorg.conf]
Comment 6 Satish Balay 2007-12-12 12:46:35 EST
Created attachment 285951 [details]
Xorg.0.log with xorg-x11-drv-ati-6.7.196-4.fc8 [without xorg.conf]
Comment 7 Satish Balay 2007-12-12 12:48:24 EST
Created attachment 285971 [details]
Xorg.0.log with xorg-x11-drv-ati-6.7.196-1.fc8 [with xorg.conf]

I'm also attaching Xorg.0.log for the working  xorg-x11-drv-ati-6.7.196-1.fc8.

Also I'm currently using kernel-
Comment 8 James Ralston 2007-12-12 14:23:22 EST
Created attachment 286081 [details]
Xorg.0.log, with xorg.conf

The is an Xorg.0.log file from an xorg-x11-drv-ati-6.7.196-1.fc8 X server that
had corrupted fonts.  The X server had an /etc/X11/xorg.conf file (as
configured by system-config-display).
Comment 9 James Ralston 2007-12-12 14:24:36 EST
Created attachment 286091 [details]
Xorg.0.log, without xorg.conf

The is an Xorg.0.log file from an xorg-x11-drv-ati-6.7.196-1.fc8 X server that
had corrupted fonts.  The X server did not have an /etc/X11/xorg.conf file.
Comment 10 James Ralston 2007-12-12 14:27:57 EST
Sorry, I got the version wrong; both of my log files (in comment 7 and comment
8) were xorg-x11-drv-ati-6.7.196-4.fc8, not xorg-x11-drv-ati-6.7.196-1.fc8.

Additionally, I'm running kernel-
Comment 11 James Ralston 2007-12-12 14:28:51 EST
(Argh; I meant comment 8 and comment 9.)
Comment 12 Matěj Cepl 2007-12-14 18:26:50 EST
*** Bug 425401 has been marked as a duplicate of this bug. ***
Comment 13 Joachim Frieben 2007-12-15 02:39:43 EST
What happens when you use the current driver plus

  Option "AccelMethod" "exa"

in your xorg.conf? Bug 425401 has been closed as a duplicate, and there,
choosing EXA solves the issue completely. Moreover, in bug 425401, only
bitmap fonts are concerned, all other, i.e. the standard antialiased
fonts, are rendered correctly. Have I understood you correctly that just
these non-bitmap fonts are affected in your case?
Comment 14 Satish Balay 2007-12-15 10:58:51 EST
Just tried using Option "AccelMethod" "exa"

The fonts in gnome-terminals & firefox are working fine with this change.

[Note: I do not know what type of fonts the are - I guess I'm using the standard
gnome fonts]

However I've noticed a few problems after this change

- draging windows arround is sluggish
- sometimes switching windows takes linger time.
- desktop background doesnt get refreshed correctly [after moving arround windows]
- nautilus [in file browser mode] background is totally messed up. Normally it
has white background. But after this change - sometimes I see blue background,
and sometimes it has black background [so no text is visible]

I'm going back to using xorg-x11-drv-ati-6.7.196-1.fc8.i386.rpm without "exa"
options now.
Comment 15 Joachim Frieben 2007-12-15 11:46:39 EST
(In reply to comment #14)
> Just tried using Option "AccelMethod" "exa"

Thanks for doing so. However, if you are using standard fonts, then they
are -not- bitmap fonts, e.g. such as "Fixed" in the font preferences of
gnome-terminal. Moreover, you seem to talk of minor artifacts whereas in
my case, it's impossible to recognize a -single- character, see


for "LucidaTypewriter". Can you confirm this?
Comment 16 Satish Balay 2007-12-15 14:01:50 EST
Created attachment 289703 [details]
screenshot of fonts

I'm attaching a sceenshot of my desktop, with the following terminals:

- firefox
- gnome-terminal with the option system-fixed-font
- gnome-terminal with LucidiaTypewriter 12 font
- xterm with the default fixed font.

The first two are broken - but the last 2 are fine for me.

The behavior I notice with the broken fonts is:
- When they are broken - the fonts are slightly smaller then they should be. So
the artifacts are at the location where the normal-size font should have been.
- when the text with the broken font is selected [with the mouse], then the
font gets reset in the selected text to the correct size, and the artifacts go
- If I change the focus to a different terminal, the fonts [in the previously
selected text] go back to the bad state.
Comment 17 Satish Balay 2007-12-20 21:51:15 EST
I've just updated to xorg-x11-drv-ati-6.7.196-5.fc8, and I don't see this
problem anymore.

I guess this issue is resolved in this update
Comment 18 James Ralston 2007-12-21 23:16:17 EST
The font corruption I was seeing is the corruption that Satish was seeing (in
the attachment in comment 16).

I was *not* seeing the corruption that Joachim is seeing (in the attachment in
comment 15).

As with Satish, when I switched to EXA acceleration, it fixed the corrupted
fonts, but introduced delays in dragging windows and switching workspaces.

With xorg-x11-drv-ati-6.7.196-5.fc8, I do not see corrupted fonts, regardless of
the acceleration method.

Note You need to log in before you can comment on or make changes to this bug.