Bug 417331 - sosreport a bit large (103 MB), needs some way to prune
sosreport a bit large (103 MB), needs some way to prune
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sos (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Navid Sheikhol-Eslami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-09 12:12 EST by Patrick C. F. Ernzer
Modified: 2008-01-08 13:55 EST (History)
0 users

See Also:
Fixed In Version: 1.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 11:57:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2007-12-09 12:12:02 EST
Description of problem:
I just generated an sosreport for another bug and the reulting file was 
surprisingly large.
We should either make sure it is small by default or at least offer the user 
the choice and include a warning along the lines of 'makes file large' just as 
we have 'slow' warnings for options already


Version-Release number of selected component (if applicable):
sos-1.6-5.fc8

How reproducible:
only tried this once, but I do not expect it to vary between runs

Steps to Reproduce:
1. make an sosreport
2. look at file size
3. look inside archive
  
Actual results:
/etc weighs in at just under 75MB and /usr at just under 135MB (uncompressed)
looking deeper, the offenders seem to be
/etc/selinux/targeted/modules/active/
/usr/share/fonts/

Expected results:
sosreport of a size that bugzilla will actually accept

Additional info:
Comment 2 Navid Sheikhol-Eslami 2007-12-10 04:38:26 EST
Looks like the majority of unnecessarily/large files were pulled in from
/etc/X11/fontpath.d - I have now added this path (and a few others) to the skip
list.

Thank you for reporting this!

-- Navid

Note You need to log in before you can comment on or make changes to this bug.