This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 417431 - Name Daemon does not gracefully shutdown
Name Daemon does not gracefully shutdown
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-09 14:42 EST by Ronald
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: 9.5.0-20.b1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 10:25:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Config file of named (1.00 KB, text/plain)
2007-12-10 08:55 EST, Ronald
no flags Details
patch (949 bytes, patch)
2007-12-10 09:02 EST, Adam Tkac
no flags Details | Diff

  None (edit)
Description Ronald 2007-12-09 14:42:35 EST
Description of problem:

Shutting down the named daemon seems to be forced.

Version-Release number of selected component (if applicable):

bind-chroot-9.5.0-18.a7.fc8
bind-libs-9.5.0-18.a7.fc8
bind-utils-9.5.0-18.a7.fc8
bind-9.5.0-18.a7.fc8


How reproducible:

Fedora 8 with bind installed:

$ service named stop

Steps to Reproduce:
1. Install Fedora 8
2. Install bind
3. Start Bind
4. Stop Bind

Actual results:

Can only be killed using the -TERM signal. Should not be needed right?

[root@Charlie ~]# service named stop
Stoppen van named: ..................................................geen
antwoord, stoppen met KILL signaal -TERM 
                                                           [  OK  ]

Expected results:

Exit with a normal termination signal.

Additional info:

I use it as a chrooted caching server.
Comment 1 Adam Tkac 2007-12-10 04:20:54 EST
Thank you for report, it's bug in initscript. But in standard situation is named
stopped with /usr/sbin/rndc utility. I'm not sure why rndc doesn't work in your
case. Could you please start named and then run "/usr/sbin/rndc stop" and attach
output? Thanks.
Comment 2 Ronald 2007-12-10 08:54:46 EST
Sorry, then I should have posted the named.conf which is now posted anyway (see
attachment). I do not have rndc enabled, I use bind as a caching server so no
controls needed... . Should I test with rndc anyway?
Comment 3 Ronald 2007-12-10 08:55:19 EST
Created attachment 282771 [details]
Config file of named
Comment 4 Adam Tkac 2007-12-10 09:02:33 EST
Created attachment 282791 [details]
patch

No tests are needed. Initscript wrongly called killproc -TERM function. I've
attached patch if you need fix this immediately because I'm going to delay
update to more serious issue
Comment 5 Fedora Update System 2007-12-20 14:49:15 EST
bind-9.5.0-20.b1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Ronald 2007-12-20 15:00:52 EST
Nope, your patch solved it :)

Note You need to log in before you can comment on or make changes to this bug.