Bug 417481 - audio has static, is quiet, since some update
audio has static, is quiet, since some update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-09 15:46 EST by Richard Schwarting
Modified: 2008-05-20 12:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 15:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig (46.58 KB, text/plain)
2007-12-09 15:46 EST, Richard Schwarting
no flags Details

  None (edit)
Description Richard Schwarting 2007-12-09 15:46:26 EST
Description of problem:
I updated my girlfriend's MacBook to-day (the first time in a few weeks), and
now the audio has some static in it.  I am not sure whether this is a problem
with alsa or pulseaudio.  

I was used to static back when I could adjust PCM and Master volume settings on
my own laptop, and the problem was usually PCM being set above 72.  I no longer
have access to these settings, it seems, due to pulseaudio.  

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.17.svn20071017.fc8

How reproducible:
Always. 

Steps to Reproduce:
1. play some music (eg. ogg123 beethoven.ogg :)
  
Actual results:
* hear music, but with static (as though PCM is too high)
* music is also quiet (even when volume from gnome-volume-control is set to max)

Expected results:
* hear music at an appropriate volume and without static

Additional info:
I am wondering whether this computer is no longer detecting its soundcard correctly.
Comment 1 Richard Schwarting 2007-12-09 15:46:26 EST
Created attachment 282341 [details]
scsconfig
Comment 2 Lubomir Kundrak 2008-03-04 16:08:39 EST
(In reply to comment #0)
> I no longer
> have access to these settings, it seems, due to pulseaudio.  

How did you access the sound card setting?
alsamixer -c 0?
How does pulseaudio affect that?
Comment 3 Lennart Poettering 2008-03-28 15:53:56 EDT
alsamixer -c0 should fix your problem.
Comment 4 Craig Kelley 2008-05-20 12:20:40 EDT
I changed my audio preferences to go back to OSS, and it fixed the problem.  The
default ALSA device shouldn't be pulseaudio if it is so broken.

Note You need to log in before you can comment on or make changes to this bug.