Bug 41752 - Everytime a program tries to connect to my BTTV card (Captivator PCI) Whole of Red Hat Freezes.
Summary: Everytime a program tries to connect to my BTTV card (Captivator PCI) Whole o...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-22 00:33 UTC by Adam Cowell
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-19 23:19:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Cowell 2001-05-22 00:33:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.4 i686)

Description of problem:
When i try and get any  program to access my BTTV card the whole system
freezes and needs me to press the reset switch. I have tried XawTV, KwinTV,
and libbgrab from Freshmeat. All have the same results. Tried compiling my
own kernel (version 2.4.4) and still have the same problem. Not ever had
the problem in previous versions of Red Hat even when compiled 2.4.3 in
RH7.0. Card also works fine in Windows still.

How reproducible:
Always

Steps to Reproduce:
1. Start X Windows
2. Load up any program such as xawtv
3. Wait as soon as program tries to access the card the system freezes
solid.

Actual Results:  System freezes and needs to be reset using reset button as
everything stalls

Expected Results:  see output from the BTTV Card (my picture from Webcam,
or Tv programmes)

Additional info:

No error messages are logged at all, computer just halts.
System is
AMD Athlon 1000Mhz
256Megs RAM
Asus K7V-133
ATI Rage 128 32Mb gfx Card
Creative DX3R Decoder card
Captivator PCI

Comment 1 Arjan van de Ven 2001-05-22 08:24:43 UTC
Could you try the following:
rm /etc/cron.d/kmod
service crond restart

(or mv the file to somewhere safe instead of rm)


Comment 2 Adam Cowell 2001-05-23 01:16:59 UTC
I tried that and has made no affect at all. Whole system still freezes just as 
it did before.

Comment 3 Alan Cox 2001-05-29 16:45:35 UTC
Is the IRQ shared and if so what with ?


Comment 4 Adam Cowell 2001-05-29 23:30:39 UTC
Yeah the IRQ seems to be shared.

 Bus  0, device  11, function  0:
    Multimedia video controller: Brooktree Corporation Bt848 TV with DMA push 
(rev 17).
      IRQ 10.
      Master Capable.  Latency=32.  Min Gnt=16.Max Lat=40.
      Prefetchable 32 bit memory at 0xdf000000 [0xdf000fff].

 Bus  0, device  17, function  0:
    Unknown mass storage controller: Promise Technology, Inc. 20265 (rev 2).
      IRQ 10.
      Master Capable.  Latency=32.  
      I/O at 0x8000 [0x8007].
      I/O at 0x7800 [0x7803].
      I/O at 0x7400 [0x7407].
      I/O at 0x7000 [0x7003].
      I/O at 0x6800 [0x683f].
      Non-prefetchable 32 bit memory at 0xdc800000 [0xdc81ffff].

The promise mass storage controller is my ATA-100 IDE controller on my M/board.

Comment 5 Adam Cowell 2002-01-21 02:47:05 UTC
This bug still exists in Red Hat 7.2, but after further testing I have
discovered it seems to be a problem with X.

Load up Xawtv (kwintv, or any other app which shows the stream from bttv card)
with no other apps at all and system and stream is fine. Load anything else
which alters on the screen in any way at all (which is 99.9% of applications
that exist) then whole system freezes. Suspect it is either a bug in X
(currently 4.1.0 or whatever comes with RH 7.2) or bttv driver.

Realised that same time installed RH 7.1 i upgraded my Video card drom a S3
virge (use X 3.3) to a Rage 128 (uses X 4.*) and the problems started then.

Comment 6 Mike A. Harris 2002-04-21 02:28:15 UTC
No BTTV hardware available in order to test/debug.  If anyone could
provide more debugging information and/or debug the X server rebuilt
with debug symbols and xfree86-gdb, that would help.  I also recommend
reporting this on xpert@xfree86.org to maximize the number of people
who might be able to look at this.

Comment 7 Adam Cowell 2002-05-19 23:18:31 UTC
Just tried in Redhat Linux 7.3 and the problem seems to no longer be around, it
now works properly. I assume it may have been a bug in xfree86, as the configs
created by xconfigurator are identical.

Comment 8 Mike A. Harris 2002-05-20 22:56:37 UTC
Ok, great.  I'll close it as fixed in CURRENTRELEASE of 7.3.  Reopen if
you experience any further problems.

Thanks.



Note You need to log in before you can comment on or make changes to this bug.