Bug 41753 - Linuxconf web hangs upon connection by browser
Summary: Linuxconf web hangs upon connection by browser
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-22 01:00 UTC by Michael Huttinger
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Huttinger 2001-05-22 01:00:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; AtHome0200)

Description of problem:
Attempting to connect to the linuxconf web services causes the "linuxconf -
-http" process to consume 100% CPU and the web client (lynx, netscape, 
IE5) simply never receives any input (waiting for response).  Must kill 
the linuxconf --http process.

How reproducible:
Always

Steps to Reproduce:
1) Installed linuxconf from Redhat 7.1 CD
2) Enabled net access from linuxconf
3) Edited /etc/xinet.d/linuxconf and set disable=no
4) Rebooted computer
5) Started:  lynx localhost:98

Actual Results:  See a "linuxconf --http" process from a: ps axu
The web client shows connected to HTTP server, waiting for response.
No response ever comes.
"linuxconf --http" process goes to 100% CPU usage

Expected Results:  Expected to see linuxconf start page.

Additional info:

Went to xinetd web site at http://www.xinetd.org/ and downloaded the 
latest sources: xinetd-2.1.8.9pre15-tar.gz
and did a 
./configure  --prefix=/usr --with-libwrap --with-loadavg
make
make install

reboot computer
did a lynx localhost:98

and up came the linuxconf stuff

Some interesting info in the readme for xinetd:
Another attempt to fix the tcp wait condition. TCP wait services were 
being accept()'d when they shouldn't.  This caused services such as 
linuxconf, which accept() their own connections, to fail.

Comment 1 Brent Fox 2002-06-05 16:17:05 UTC
Closing because we don't ship linuxconf anymore

Comment 2 Red Hat Bugzilla 2006-02-21 18:48:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.