Bug 417691 - nxloadconfig errors
nxloadconfig errors
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freenx-server (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 01:18 EST by Need Real Name
Modified: 2008-08-16 09:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.7.2-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-16 09:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated patch (12.04 KB, application/octet-stream)
2007-12-31 13:49 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2007-12-10 01:18:49 EST
Description of problem:
Running 'nxloadconfig --check' generates a number of errors.

The error message is as follows:
Warning: Invalid value
"APPLICATION_LIBRARY_PRELOAD=/usr/lib/nx/libX11.so.6.2:/usr/lib/nx/libXext.so.6\
.4:/usr/lib/nx/libXcomp.so:/usr/lib/nx/libXcompext.so:/usr/lib/nx/libXrender.so\
.1.2". /usr/lib/nx/libXcomp.so could not be found. Users will not be able to ru\
n a single application in non-rootless mode.
Warning: Invalid value
"COMMAND_FOOMATIC=/usr/lib/cups/driver/foomatic-ppdfile"
         Users will not be able to use foomatic.
Warning: Invalid value "DEFAULT_X_SESSION=/etc/X11/xdm/Xsession"
         Users might not be able to request a default X session.
-----------------------------------

Note that the APPLICATION_LIBRARY_PRELOAD error used to not happen before since
the value in  previous versions of freenx use /usr/lib/nx/libXcomp.so.2
(which does exist) rather than /usr/lib/nx/libXcomp.
It seems to me that the solution is either to change the value in
APPLICATION_LIBRARY_PRELOAD back to /usr/lib/nx/libXcomp.so.2 or to
create a link from libXcomp.so.2 to libXcomp.so

The COMMAND_FOOMATIC error can be corrected by changing:
    COMMAND_FOOMATIC="/usr/lib/cups/driver/foomatic-ppdfile"
to:
    COMMAND_FOOMATIC="/usr/bin/foomatic-ppdfile"
The DEFAULT_X_SESSION error can be corrected by changing
    DEFAULT_X_SESSION=/etc/X11/xdm/Xsession
to:
    DEFAULT_X_SESSION=/etc/X11/xinit/Xsession


Note that a close examination of the nxloadconfig file reveals several other
errors but they probably are not critical. 

First there are two path errors that end up being caught internally by tests and
replaced using the 'which' command so that they end up working out
anyway. However, you still may want to correct them for "cleanliness" sake:
1. COMMAND_XAUTH=/usr/X11R6/bin/xauth
   Whereas the real location on F8 is /usr/bin/xauth.

2. COMMAND_VNCPASSWD="$PATH_BIN/nxpasswd"
   Whereas the real location on F8 is /usr/bin/nxpasswd

Second, several assignments reference /usr/NX which doesn't exist on
my installation but it doesn't seem to have any effect on NX.
   SERVER_FORWARD_KEY="/usr/NX/share/client.id_dsa.key"
   NOMACHINE_SERVER="/usr/NX/bin/nxserver"
   NOMACHINE_NX_HOME_DIR="/usr/NX/home/nx"

This may relate to the NoMachines version of the nxserver so it may not be
important to fix.

----------------------------------------------------------------------------
Note also that samba shares and printer shares still don't work right out of the
box and I have submitted a number of bug fixes and enhancements to Fabian
(several of which are already included in 0.7.1).

On my system, even multimedia doesn't work out of the box unless you change the
value of DISPLAY_BASE since it conflicts with NASD on port 8000.
Comment 1 Need Real Name 2007-12-31 11:03:56 EST
Axel, note that my patch given in
https://bugzilla.redhat.com/show_bug.cgi?id=216802 addresses all the critical
errors mentioned here.

I did *not* change the paths for
   COMMAND_XAUTH
   COMMAND_VNCPASSWD

and I did not change any of the variables that reference /usr/NX.

As mentioned above, those are all non-critical errors since they are either
corrected by the script or unnecessary for proper functioning of NX -- hence, I
chose to not (yet) include them in my patch.

If you think that any of the above should be patched for "cleanliness" sake, I
would be happy to add them to my patch and repost...

Otherwise, this bug can be marked either as closed or as a duplicate of the
above mentioned bug.
Comment 2 Axel Thimm 2007-12-31 12:10:55 EST
Would the new paths remove the which functionality? I'd prefer to keep freenx
"which"ing the proper paths if it doesn't find them - that way the specfile will
work on RHEL as well. :)
Comment 3 Need Real Name 2007-12-31 13:03:28 EST
The paths that I patched don't change the which functionality -- in fact, I
changed them because they didn't work before with hard-wired paths.

Now 'which' would generally work if you dropped the full path for
COMMAND_FOOMATIC and set it to just foomatic-ppdfile since it is stored in
/usr/bin which is part of a typical path. However, it won't generally work for
DEFAULT_X_SESSION since at least on Fedora, XSession is stored in /etc/X11/xdm
which is not typically part of a standard path.

So, I guess the bottom line is feel free to change COMMAND_FOOMATIC to
foomatic-ppdfile but there is no simple solution for DEFAULT_X_SESSION.

Also, for consistency and now that I understand your concern, I will make
similar changes to COMMAND_XAUTH and COMMAND_VNC.

I will repost an updated diff shortly..
Comment 4 Need Real Name 2007-12-31 13:05:22 EST
Oops I meant COMMAND_VNCPASSWD not COMMAND_VNC.

Also, I'm going to leave the commands with 'sbin' in them as fixed paths since
many users don't have sbin in their path.
Comment 5 Need Real Name 2007-12-31 13:49:57 EST
Created attachment 290588 [details]
Updated patch

Note I also now corrected two of the library names in APPLICATION_LIBRARY_PATH
in nxloadconfig.

The original names listed are libXcomp.so and libXcompext.so while the
directory /usr/lib/nx has the versions libXcomp.so.2 and libXcompext.so.2

Of course, an alternative approach would be to change the rpm spec file to
create links. Let me know if you think that is a better approach.

Otherwise, nxloadconfig --check now runs about as clean as you can get it. Note
that the warnings about smbmount and smbumount are not accurate since you can
use SAMBA with mount.cifs/umount.cifs
Comment 6 Need Real Name 2008-01-15 14:09:42 EST
Any idea when patched version will be added to updates?
Comment 7 Axel Thimm 2008-04-11 12:20:44 EDT
This is a collective comment for freenx bugs. There is a new release packaged as
freenx-server-0.7.2-7 in rawhide and soon in updates-testing. Please test it and
see whether it fixed your report.

Also note that freenx has been split into freenx-server and freenx-client. All
current open bug reports will move to freenx-server once it is created in bugzilla.
Comment 8 Axel Thimm 2008-04-24 04:37:48 EDT
freenx has been split into freenx-server and freenx-client. Most open bugs for
freenx addressed parts of the current freenx-server package. See also bug #438660.

freenx-server is currently in testing repos. Please give it a try as it will
soon replace the freenx package.

Note You need to log in before you can comment on or make changes to this bug.