Bug 417811 - Not possible to load OOo components (damaged conf files)
Not possible to load OOo components (damaged conf files)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 04:59 EST by David García Granda
Modified: 2007-12-14 12:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-14 08:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Latest entries in yum.log fiel (3.01 KB, text/plain)
2007-12-10 12:19 EST, David García Granda
no flags Details
Common-unx.xcu corrupted file (580 bytes, application/octet-stream)
2007-12-10 12:20 EST, David García Granda
no flags Details
Configuration.xcu corrupted file (4.63 KB, application/octet-stream)
2007-12-10 12:21 EST, David García Granda
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 84394 None None None Never

  None (edit)
Description David García Granda 2007-12-10 04:59:08 EST
Description of problem:

Not possible to load any of the OpenOffice.org components (Writer, Impress,
etc.). When trying, files:

/usr/lib/openoffice.org/share/registry/modules/org/openoffice/Office/Common/Common-unx.xcu

/usr/lib/openoffice.org/share/registry/data/org/openoffice/ucb/Configuration.xcu

are damaged (bin files, not sure what has been wrong when updating) and a couple
of pop-up windows notice the problem.

No OOo application can be loaded afterwords.

Version-Release number of selected component (if applicable):

OpenOffice.org core rpm version is: openoffice.org-core-2.3.0-6.7.fc8-i386

How reproducible:

Always

Steps to Reproduce:

Trying to load any OpenOffice.org component
  
Additional info:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules//drivers/v4l_drv.so
(II) Loading /usr/lib/xorg/modules//drivers/nv_drv.so
(--) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-33-i386
(V)    kernel is: Linux 2.6.23.8-63.fc8 #1 SMP Wed Nov 21 18:51:08 EST 2007 i686
i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.3.0-6.7.fc8-i386
(VII)  accessibility is: false
(VIII) fedora release is: Fedora release 8 (Werewolf)
...start free space details ...
S.ficheros         Bloques de 1K   Usado    Dispon Uso% Montado en
/dev/sda6              7558368   3120360   4054060  44% /home
/dev/sda5              9920592   5137024   4271500  55% /
...end free space details ...
...start stackreport details ...
0x030681a9: 0x001cd374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x211a9
0x03068c6e: 0x001cd374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x21c6e
0x00110420: 0x00000000:  + 0x420 (__kernel_sigreturn + 0x0)
0x007d10ac: 0x00154d7c: /lib/libc.so.6 + 0x6d0ac (cfree + 0x4c)
0x0057b8c1: 0x000c90c4: /lib/libglib-2.0.so.0 + 0x348c1 (g_free + 0x31)
0x0156209a: 0x0005f7e8: /usr/lib/libgnomevfs-2.so.0 + 0x1c09a
(gnome_vfs_file_info_clear + 0x3a)
0x0155f4b9: 0x0005f7e8: /usr/lib/libgnomevfs-2.so.0 + 0x194b9
(gnome_vfs_directory_read_next + 0x39)
0x01532247: 0x0003098c: /usr/lib/openoffice.org/program/ucpgvfs1.uno.so +
0x1f247 (gvfs::DataSupplier::getData() + 0x1ab)
0x0153237c: 0x0003098c: /usr/lib/openoffice.org/program/ucpgvfs1.uno.so +
0x1f37c (gvfs::DataSupplier::getResult(unsigned long) + 0x44)
0x006aefc4: 0x0007e7c0: /usr/lib/openoffice.org/program/libucbhelper4gcc3.so +
0x41fc4 (ucbhelper::ResultSet::next() + 0x4c)
0x02ac1642: 0x00012984: /usr/lib/openoffice.org/program/libfileacc.so + 0x6642
0x033a5a4f: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0xeaa4f
0x033a5e0b: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0xeae0b
0x033a62ae: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0xeb2ae
0x03377269: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0xbc269
(BitmapEx::BitmapEx(ResId const&) + 0x12d)
0x00e62ff0: 0x00058af0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x37ff0
0x00e5ec14: 0x00058af0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x33c14
0x00e5f053: 0x00058af0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x34053
0x00e6218f: 0x00058af0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x3718f
0x00e417da: 0x00058af0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x167da
0x034d3a01: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x218a01
0x0346b373: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x1b0373
0x0346b486: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x1b0486
0x034e1f8d: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x226f8d
0x034e21e4: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so +
0x2271e4 (WorkWindow::WorkWindow(Window*, long long) + 0x4c)
0x043d9208: 0x001ff110: /usr/lib/openoffice.org/program/libtk680li.so + 0x96208
0x043d980a: 0x001ff110: /usr/lib/openoffice.org/program/libtk680li.so + 0x9680a
0x043d9a20: 0x001ff110: /usr/lib/openoffice.org/program/libtk680li.so + 0x96a20
0x06e963c1: 0x0027f21c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x1703c1
0x06e967da: 0x0027f21c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x1707da
0x06da624f: 0x0027f21c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x8024f
0x06d6ae5e: 0x0027f21c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x44e5e
0x06e2694f: 0x0027f21c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x10094f
0x06e2703a: 0x0027f21c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x10103a
0x06e27718: 0x0027f21c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x101718
0x06d69625: 0x0027f21c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x43625
0x03efc815: 0x000622ec: /usr/lib/openoffice.org/program/libsoffice.so + 0x39815
(desktop::DispatchWatcher::executeDispatchRequests(_STL::vector<desktop::DispatchWatcher::DispatchRequest,
_STL::allocator<desktop::DispatchWatcher::DispatchRequest> > const&) + 0x1157)
0x03ef47f0: 0x000622ec: /usr/lib/openoffice.org/program/libsoffice.so + 0x317f0
(desktop::OfficeIPCThread::ExecuteCmdLineRequests(desktop::ProcessDocumentsRequest&)
+ 0x172)
0x03ee24c4: 0x000622ec: /usr/lib/openoffice.org/program/libsoffice.so + 0x1f4c4
(desktop::Desktop::OpenDefault() + 0x2c0)
0x03eeb305: 0x000622ec: /usr/lib/openoffice.org/program/libsoffice.so + 0x28305
(desktop::Desktop::OpenClients() + 0x12cf)
0x03eeb359: 0x000622ec: /usr/lib/openoffice.org/program/libsoffice.so + 0x28359
(desktop::Desktop::OpenClients_Impl(void*) + 0x2f)
0x03eeb401: 0x000622ec: /usr/lib/openoffice.org/program/libsoffice.so + 0x28401
(desktop::Desktop::LinkStubOpenClients_Impl(void*, void*) + 0x1d)
0x0334cb93: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x91b93
0x034dd55e: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x22255e
0x00ee82c9: 0x000826bc: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x1f2c9
0x00f10e6a: 0x000826bc: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x47e6a (SalDisplay::DispatchInternalEvent() + 0x78)
0x00e3f679: 0x00058af0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x14679
0x00e3f6a8: 0x00058af0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x146a8
0x00572541: 0x000c90c4: /lib/libglib-2.0.so.0 + 0x2b541
0x0057410c: 0x000c90c4: /lib/libglib-2.0.so.0 + 0x2d10c (g_main_context_dispatch
+ 0x17c)
0x0057754f: 0x000c90c4: /lib/libglib-2.0.so.0 + 0x3054f
0x00577ab5: 0x000c90c4: /lib/libglib-2.0.so.0 + 0x30ab5
(g_main_context_iteration + 0x65)
0x00e3f4a8: 0x00058af0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x144a8
0x00f170bd: 0x000826bc: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x4e0bd (X11SalInstance::Yield(bool, bool) + 0x2f)
0x03354ddf: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x99ddf
(Application::Yield(bool) + 0x57)
0x03354e9d: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x99e9d
(Application::Execute() + 0x2b)
0x03ee77db: 0x000622ec: /usr/lib/openoffice.org/program/libsoffice.so + 0x247db
(desktop::Desktop::Main() + 0x15fb)
0x03359933: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9e933
0x03359a49: 0x003d903c: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9ea49
(SVMain() + 0x2d)
0x03ee0e3e: 0x000622ec: /usr/lib/openoffice.org/program/libsoffice.so + 0x1de3e
(main + 0xe2)
0x0077a390: 0x00154d7c: /lib/libc.so.6 + 0x16390 (__libc_start_main + 0xe0)
0x080484e1: 0x000006f8: /usr/lib/openoffice.org/program/swriter.bin + 0x4e1
(main + 0x59)
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00110000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00170000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00577000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00611000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x0062d000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00649000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00653000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x00694000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x00718000)
	libdl.so.2 => /lib/libdl.so.2 (0x0071c000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x00721000)
	librt.so.1 => /lib/librt.so.1 (0x00726000)
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00762000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x0077f000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x007be000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x007fe000)
	libvclplug_gen680li.so =>
/usr/lib/openoffice.org/program/libvclplug_gen680li.so (0x008c8000)
	libvcl680li.so => /usr/lib/openoffice.org/program/libvcl680li.so (0x00951000)
	libpsp680li.so => /usr/lib/openoffice.org/program/libpsp680li.so (0x00d31000)
	libsot680li.so => /usr/lib/openoffice.org/program/libsot680li.so (0x00e35000)
	libutl680li.so => /usr/lib/openoffice.org/program/libutl680li.so (0x00e9d000)
	libtl680li.so => /usr/lib/openoffice.org/program/libtl680li.so (0x00f3b000)
	libcomphelp4gcc3.so => /usr/lib/openoffice.org/program/libcomphelp4gcc3.so
(0x00fe8000)
	libucbhelper4gcc3.so => /usr/lib/openoffice.org/program/libucbhelper4gcc3.so
(0x045e3000)
	libuno_cppuhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_cppuhelpergcc3.so.3 (0x0497b000)
	libuno_cppu.so.3 => /usr/lib/openoffice.org/program/libuno_cppu.so.3 (0x03f67000)
	libvos3gcc3.so => /usr/lib/openoffice.org/program/libvos3gcc3.so (0x03edb000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/program/libuno_sal.so.3 (0x06037000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x01166000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x0072f000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x065d0000)
	libstlport_gcc.so => /usr/lib/openoffice.org/program/libstlport_gcc.so (0x07b06000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x07e6c000)
	libm.so.6 => /lib/libm.so.6 (0x067b0000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x0644a000)
	libc.so.6 => /lib/libc.so.6 (0x01ca9000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x0073f000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x06756000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x06864000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x063f0000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x0633c000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x01114000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x063b4000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x0640e000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x068a0000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x0734a000)
	libz.so.1 => /lib/libz.so.1 (0x0651c000)
	/lib/ld-linux.so.2 (0x00745000)
	libnsl.so.1 => /lib/libnsl.so.1 (0x0111d000)
	libcap.so.1 => /lib/libcap.so.1 (0x01136000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x01139000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x01142000)
	libi18nisolang1gcc3.so =>
/usr/lib/openoffice.org/program/libi18nisolang1gcc3.so (0x0115c000)
	libbasegfx680li.so => /usr/lib/openoffice.org/program/libbasegfx680li.so
(0x06279000)
	libicuuc.so.38 => /usr/lib/libicuuc.so.38 (0x01262000)
	libicule.so.38 => /usr/lib/libicule.so.38 (0x0620b000)
	libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org/program/libjvmaccessgcc3.so.3
(0x01391000)
	libjvmfwk.so.3 => /usr/lib/openoffice.org/program/libjvmfwk.so.3 (0x0139a000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x013b9000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x013be000)
	libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x01163000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x013f0000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x0140c000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x03121000)
	libicudata.so.38 => /usr/lib/libicudata.so.38 (0xb74d9000)
	libxml2.so.2 => /usr/lib/libxml2.so.2 (0x04477000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x02f3b000)
...end sample ldd details ...
Comment 1 Caolan McNamara 2007-12-10 05:17:12 EST
If the files have become corrupt then we're just screwed. I sort of doubt we
have an inherent openoffice.org problem here, but something more generic. Can
you attach your /var/log/yum.log. Was there anything else unusual going on,
anything else broken or warnings spewed out elsewhere ?

You might as well attach the corrupt files of...
/usr/lib/openoffice.org/share/registry/modules/org/openoffice/Office/Common/Common-unx.xcu
/usr/lib/openoffice.org/share/registry/data/org/openoffice/ucb/Configuration.xcu
so I could at least add some defensive work on the corrupt configuration route.
Comment 2 David García Granda 2007-12-10 12:19:03 EST
Created attachment 282931 [details]
Latest entries in yum.log fiel
Comment 3 David García Granda 2007-12-10 12:20:25 EST
Created attachment 282941 [details]
Common-unx.xcu corrupted file

Path:
/usr/lib/openoffice.org/share/registry/modules/org/openoffice/Office/Common/Common-unx.xcu
Comment 4 David García Granda 2007-12-10 12:21:06 EST
Created attachment 282951 [details]
Configuration.xcu corrupted file

Path:
/usr/lib/openoffice.org/share/registry/data/org/openoffice/ucb/Configuration.xcu
Comment 5 David García Granda 2007-12-10 12:24:47 EST
I didn't realize any errors when updating, but it looks like a problem with the
ES localization as I updated another box (without language localization) and it
worked fine. Currently installed rpms on the box I experience problems:

[david@portdav ~]$ rpm -qa | grep openoffice
openoffice.org-graphicfilter-2.3.0-6.7.fc8
openoffice.org-xsltfilter-2.3.0-6.7.fc8
openoffice.org-calc-2.3.0-6.7.fc8
openoffice.org-writer-2.3.0-6.7.fc8
openoffice.org-math-2.3.0-6.7.fc8
openoffice.org-impress-2.3.0-6.7.fc8
openoffice.org-core-2.3.0-6.7.fc8
openoffice.org-draw-2.3.0-6.7.fc8
openoffice.org-langpack-es-2.3.0-6.7.fc8
[david@portdav ~]$

Hope it helps!
Comment 6 Caolan McNamara 2007-12-14 08:46:11 EST
The Configuration.xcu looks like some sort of broken .zip file all very strange.
I've tried installing the same set of openoffice.org-*-2.3.0-6.6.fc8's and
upgrading to openoffice.org-*-2.3.0-6.7.fc8 and didn't get any such problems.

I strongly suspect that it's not related to OOo, but e.g. a generic problem
revealed by a large update. I'd check the output of smartctl to see if your disk
is dying, e.g. smartctl -l error /dev/sda

Comment 7 David García Granda 2007-12-14 12:06:27 EST
I have just removed all OOo components and installed them again and it works, so
I agree may be due to constant updates on this box, thanks for your help.

Hopefully no errors in my hard disk, thanks for the tip.

Note You need to log in before you can comment on or make changes to this bug.