Bug 417831 - Can't run buildinstall
Can't run buildinstall
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 05:34 EST by Gary Thomas
Modified: 2008-08-06 16:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 16:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output/log from buildinstall command (176.76 KB, text/plain)
2007-12-10 05:34 EST, Gary Thomas
no flags Details

  None (edit)
Description Gary Thomas 2007-12-10 05:34:00 EST
Description of problem:

Running buildinstall against the F8 tree yields a multitude
of errors.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Copy release tree to '/tmp/test_i386'
2. buildinstall --version 8 --product "Fedora" --release "Fedora Test"
--prodpath Packages --discs ALL /tmp/test_i386/os
3.
  
Actual results:

Logfile attached.

Expected results:


Additional info:

This same command sequence worked with FC6 and before.  I really
need to build a "distribution" from adjusted package set and this
is the only way I know how.  I'm experimenting with the LiveCD
path, but that's still to come.
Comment 1 Gary Thomas 2007-12-10 05:34:00 EST
Created attachment 282601 [details]
Output/log from buildinstall command
Comment 2 Chris Lumens 2007-12-10 11:26:14 EST
Are you running buildinstall as root?  chroot isn't in a regular user's path,
which is probably what you're seeing in the error messages.
Comment 3 Gary Thomas 2007-12-10 11:34:06 EST
Yes, of course.
Comment 4 Gary Thomas 2007-12-10 11:42:02 EST
FAOD - I am logged in as root and can run 'chroot' from the same shell/prompt
where I run buildinstall.

Also, looking at the logs, there are *many* other errors (missing files and
directories), syntax errors when running 'sed', etc.

Whatever is wrong here, it happens "out of the box".  Of course, it could
be cockpit/operator error, but I just need to know what's up and how to fix it.
Comment 5 Joel Andres Granados 2008-05-07 11:27:06 EDT
The buildinstall scripts when through a mayor rewrite and what we currently have
in f9 is very different from what we had in f8 and before.
In the previous releases there where some errors in the output because
buildinstall and related scripts were very messy and let some error messages
through.  ATM we are trying to do our best to patch these error messages by
piping everything to /dev/null.
Can you please test once more and see if the chroot and sed errors still occur
with the current release of f9.

Moreover. might want to give revisor and pungi a try.  They are, AFAIK, very
usefull tools.

Note You need to log in before you can comment on or make changes to this bug.