Bug 41790 - Installer fails on 3ware Escalade 6200 (corrupt partition table)
Installer fails on 3ware Escalade 6200 (corrupt partition table)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 00:47 EDT by Eric George
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 14:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric George 2001-05-22 00:47:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16 i686)

Description of problem:
I get to the point in the installation where it requests the instalation
type (workstation, server, etc.)  When I hit <next> from here, a window
pops up saying that sda (the 3ware controlled volume) has a corrupt
partition table.  Retrying doesn't help, so the installation fails.

At the beginning of the installation a small window briefly popped up
saying that it was loading the 3ware drivers.

sda currently contains a Mandrake 8.0 install on a RAID 1 volume (2x 20GB
Maxtor).
I wish to overwrite this .

How reproducible:
Always

Steps to Reproduce:
1.Boot from install CD
2.Also tried expert mode with same result.
3.
	

Actual Results:  As descibed above.

Expected Results:  Should have detected the drive properlyand let me
continue with the install.

Additional info:

The system runs fine with Mandrake 8.0 (except for some stability problems,
which is why I'm trying RH7.1).  It will currently boot up the Mandrake
install, so I'm pretty confident that the drives & controller are OK.

Most of the Mandrake install is on ReiserFS if that matters.

Some Specs:
IWill KK266
AMD ThunderBird-C 1200 MHz
384 MB PC133 RAM
3ware Escalade 6200 IDE RAID controller
2x20 GB Maxtor 7200 RPM drives
GeForce2 MX video
Ensoniq 1371 based PCI sound card.
CD, CDRW, Zip on onboard IDE controllers.
Comment 1 Brent Fox 2001-05-22 08:59:24 EDT
I'm thinking that our installer might not be able to recognize the partition
table that Mandrake set up.  That's just a guess though.  

Here are two options I can think of:
1) Use fdisk to wipe the Mandrake partitions off the drive.  You can do that
with the installer if you go to VC2 *before* the screen that causes the error
message.  Once you're at VC2, say 'mknod sda' and then 'fdisk sda'.  You should
then be able to wipe the existing partitions off the drive.

2)Boot the Red Hat installer with 'linux expert'.  That should keep the
installer from probing the drive.

Does this help?
Comment 2 Eric George 2001-05-22 11:45:45 EDT
Seems strange that RedHat would fail to recognize partitions created by another 
Linux distro.  Particularly a RedHat derivative.  Anyway...

I suspect that fdisk will solve the problem.  Kinda hurts if you want to dual 
boot though.  I don't right now, so I'll probably try that.

BTW: What is 'VC2"?

I did try the expert mode.  It eventually brought me back to the same place and 
came back with the same error.

I'll retry the expert mode, and then fdisk if this doesn't work.  Won't be 
until tonight though.
Thanks
Eric
Comment 3 Brent Fox 2001-05-22 16:24:29 EDT
What I meant was that we might have trouble recognizing the ReiserFS partitions,
which our installer doesn't set up (currently).  Like I said, that was just a
guess.  I'm not really sure whether the problem is a combination of the 3ware
card and ReiserFS...I don't have a lot of experience with either of those.
Normally, dual booting distros isn't a problem.  It's something that I test on
my test machines, so that usually works.

VC2 is the second virtual console...press <Ctrl><Alt><F2> and you'll be at a
root shell inside the installer environment.  You can then run fdisk from there
if you need to.

Let us know if the installer worked after fdisking the drive.
Comment 4 Brent Fox 2001-06-01 14:29:35 EDT
Closing due to inactivity. Please reopen if you have more information.
Comment 5 Eric George 2001-06-02 16:01:05 EDT
Sorry it took so long.  I didn't get back to it until this morning.

Using fdisk to delete the existing partitions solved the problem.  The install
went fine from that point.
Thanks

Note You need to log in before you can comment on or make changes to this bug.