This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 41791 - GLw* missing from XFree86-devel
GLw* missing from XFree86-devel
Status: CLOSED DUPLICATE of bug 41974
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 01:06 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-03 23:02:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-22 01:06:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
The XFree86-devel package contains the man pages for the "GLw" widget set,
but it  doesn't contains the corresponding header files or the actual
library. It should have at least "GLwDrawA.h" and "GLwMDrawA.h" (and most
likely others as well).

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql XFree86-devel | grep GLw

Actual Results:  1.
  /usr/X11R6/man/man3/GLwCreateMDrawingArea.3x.gz
  /usr/X11R6/man/man3/GLwDrawingArea.3x.gz
  /usr/X11R6/man/man3/GLwDrawingAreaMakeCurrent.3x.gz
  /usr/X11R6/man/man3/GLwDrawingAreaSwapBuffers.3x.gz
  /usr/X11R6/man/man3/GLwMDrawingArea.3x.gz

Expected Results:  There should have been entries for header files and a
library file rather than just man pages. 

Additional info:

Using XFree86-4.0.3-5.i386.rpm
Comment 1 Mike A. Harris 2001-05-31 21:58:24 EDT
The manpages have now been removed from the package.  Thanks for pointing out
the extra stuff that shouldn't have been there.  Should be in Rawhide soon.
Comment 2 Need Real Name 2001-06-03 19:01:55 EDT
Since you've removed the manpages from XFree86-devel rather than added the
corresponding GLw* headerfiles, where have they been moved to ? These files (the
headers and the GLw library) are needed to build SGI's Openinventor, and I'm
sure other packages depend on them too.
Comment 3 Mike A. Harris 2001-06-03 23:05:39 EDT
This RFE is a duplicate, please follow up on the duplicate bug if you
would like to keep track of the status of this.  I've added you to the CC
for the other report.

*** This bug has been marked as a duplicate of 41974 ***

Note You need to log in before you can comment on or make changes to this bug.