Bug 41793 - RPM database corrupted because of Ximian GNOME installation
RPM database corrupted because of Ximian GNOME installation
Status: CLOSED DUPLICATE of bug 38454
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 01:54 EDT by Eetu Huisman
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-23 08:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tarball of my RPM database (deleted)
2001-05-22 02:02 EDT, Eetu Huisman
no flags Details
tarball of my database (deleted)
2001-05-22 14:26 EDT, Eetu Huisman
no flags Details

  None (edit)
Description Eetu Huisman 2001-05-22 01:54:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.14-5.0 i686)

Description of problem:
I installed Ximian GNOME 1.4 and now when I try to run any graphical rpm
maintenance tool, I get the following error message:

[program name here]: header.c:511: headerLoad: Assertion `rdlen == dl'
failed.

How reproducible:
Didn't try

Steps to Reproduce:
Well, try to install Ximian GNOME and Nautilus and then update some
packages and...
	

Actual Results:  Described above...

Expected Results:  Well, everything should run smoothly, of course

Additional info:
Comment 1 Jeff Johnson 2001-05-22 12:17:54 EDT
Please attach a pointer to a tarball of your database
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz
and I'll take a look. Thanks.
Comment 2 Jeff Johnson 2001-05-23 11:12:29 EDT
OK, record #662 is damaged. I'll attach a toy program to delete an
entry from a Berkeley DB, edit 662 into the top, compile with
        cc -o t38454 t38454.c -ldb-3.1
(from memory, unchecked, see bugzilla #38454), run the progem, and
then do a --rebuilddb -vv to recreate the inverted lists.

Meanwhile, yet another assertion has been removed from header.c, I
should have a version of rpm that ignores bad records on ftp.rpm.org
Real Soon, will then move on to insturmenting the record deletion.

Off to #38454

*** This bug has been marked as a duplicate of 38454 ***

Note You need to log in before you can comment on or make changes to this bug.