Bug 41798 - kickstart don't use the driver disk on a brand new system
kickstart don't use the driver disk on a brand new system
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 04:21 EDT by Eric Doutreleau
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 04:21:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Doutreleau 2001-05-22 04:21:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.2.17-14 i686)

Description of problem:
I 'm trying to kickstart install a bunch of new station with nothing
on disk.
Interactive installaiton work fine and i generate a kickstart file
whith mkkickstart.

The problem is that the ethernet driver is on the driver disk.
As there are new machine with new disk there s no filesystem on
the machine then i can 't use the driverdisk options in my
kickstart file.
I have tried to use
linux dd ks=floppy in the boot prompt but it never ask for the
driver disk.

Then It seems i can 't install these machine with kickstart.

How reproducible:
Always

Steps to Reproduce:
1. find a machine whenre the ethernet driver is not on the bootnet disk
2. install it interactively
3. make a kickstart floppy
4. try to kickstart install the machine	

Additional info:
Comment 1 Brent Fox 2001-05-22 09:09:45 EDT
This problem has been reported in the past.  It will be fixed in future versions
of Red Hat Linux, but I've put together a new boot disk that should allow 'linux
dd ks=floppy' to pull in a driver disk.  It is available at
people.redhat.com/bfox/bootnet.img.

Note You need to log in before you can comment on or make changes to this bug.