Bug 41803 - RPM api manpages not in /usr/share/man/man3
Summary: RPM api manpages not in /usr/share/man/man3
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-22 09:23 UTC by Mike A. Harris
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 09:23:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2001-05-22 09:23:19 UTC
The man pages for the RPM API are not contained in the system manpage
directories, and are as such, not in the manpath.  They are currently
located in /usr/share/doc/rpm-devel-4.0.x/apidocs/man3

These should be moved to the proper location so that man can find them.

Comment 1 Jeff Johnson 2001-05-22 16:15:46 UTC
I disagree because
	1) doxygen generated man pages are a bit frothy. For example,
	almost every function in rpm is documented, and doxygen spits a
	different man page for each. Overkill, IMHO.
	2) the documentation is a bit flimsy, adding to /usr/share/man is
	just gonna create a mass of tedious bug reports about
	insignificant minutiae.
	3) there are only a handful of people who are programming
	directly against rpmlib. Over 50% of those people are me,
	myself, and I, and I certainly don't need or want man pages
	in /usr/share/man

I expect that the doxygen generated man pages will be ripped out at
some point, possibly the apidocs as well. It's early yet ...


Note You need to log in before you can comment on or make changes to this bug.