Bug 418101 - Timezone database updates at the OS Level does not reflect at the Java Level
Timezone database updates at the OS Level does not reflect at the Java Level
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 09:11 EST by Robert Marcano
Modified: 2007-12-10 12:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 12:31:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Marcano 2007-12-10 09:11:39 EST
Description of problem:

Timezone database updates at the OS Level does not reflect at the Java Level

Icedtea (and any OpenJDK based JVM) uses an internal version of the database,
compiled using and non zic compatible tool, it would be interesting and useful
if that tool used to compile the icedtea database can be used to include the
java version of it on the tzdata package, or better yet make icedtea understand
the system one, in order to the change can be made system wide.

Do openoffice has an internal database? I am thinking that must be true because
Windows has no central database for TZ changes historical data, only current TZ
offset and daylight savings information (MS Office requires a separate update
than the OS)
Comment 1 Thomas Fitzsimmons 2007-12-10 12:12:43 EST
(In reply to comment #0)
> Description of problem:
> 
> Timezone database updates at the OS Level does not reflect at the Java Level

Do you have tzdata-java installed?
Comment 2 Robert Marcano 2007-12-10 12:31:11 EST
ohhh my mistake, Local rsynced mirror was not correctly updated, this saturday
(the day before the change in my country was made) so only part of the updates
where available, problem fixed, nice to know the zoneifo is already on another RPM.

Note You need to log in before you can comment on or make changes to this bug.