Bug 41813 - (SCSI AIC7XXX)Installer hangs when loading aic7xxx driver
(SCSI AIC7XXX)Installer hangs when loading aic7xxx driver
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-05-22 10:41 EDT by Michael Hall
Modified: 2007-04-18 12:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-12 13:33:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Hall 2001-05-22 10:41:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
I installed RH7.1 without any problems.  However, I bought a DiamondMax 
40GB HD, so I upgraded my BIOS in order for my system to see the 40GB.  I 
went to reinstall RH7.1 in order to use the XFS filesystem.  Now when the 
install program is loading the aic7xxx driver the install hangs.

I have a VA-503+ MOBO, AMD K6-II 500, and 396MB RAM.  The part number for 
the BIOS upgrade was F2A5LEF09, it is an AWARD BIOS.  My HDs are one IDE 
Maxtor DiamondMax 40GB.  Two SCSI drives, one Western Digital 9.1GB and 
one Segate 1.0GB.  

I tried the "text noprobe" option and I just get a list of drivers and I 
see not alternate aic7xxx driver to select.  

As a side note, I tried to put in my old buslogic controller and the 
install hung installing the driver for that also.  

How reproducible:

Steps to Reproduce:
1.  Run the install program

Additional info:
Comment 1 Brent Fox 2001-05-22 11:18:09 EDT
Does booting with 'linux ide=nodma' help?
Comment 2 Michael Hall 2001-05-22 20:44:11 EDT
I gave that a try this evening.  No Luck the installer still hangs on the 
aic7xxx driver.  If I try to boot into the 7.1 version I previously installed 
the system hangs and the last few lines on the screen say:

SCSI subsystem driver Revision: 1.00
Loading sd_mod module
Loading aic7xxx module
PCI: Assigned IRW 15 for device 00:08.0
(scsi0) <Adaptec AHA-294X SCSI host adapter> found at PCI 0/8/0
(scsi0) Narrow Channel, SCSI ID=7, 16/255 SCBs
(scsi0) Downloading sequencer code... 415 instructions downloaded

Then the system hangs.  I don't know if this information will help but I 
thought it might.
Comment 3 Michael Hall 2001-05-22 20:46:09 EDT
Sorry about that that should be IRQ 15.
Comment 4 Brent Fox 2001-05-24 11:55:40 EDT
This looks like a kernel bug.
Comment 5 Arjan van de Ven 2001-05-24 12:04:53 EDT
"I went to reinstall RH7.1 in order to use the XFS filesystem"
does this mean you are using the install floppy SGI made ?
Comment 6 Jeff Hazard 2001-05-29 16:19:38 EDT
I'm using two adaptec scsi cards in my system..29xx and 39xx. with an ASUS  P3V4X . I was having the same  install problems.
The new code in kernel 2.4.5 fixes my adaptec problems, compiling the adaptec driver into the kernel while selecting disable tagged queing on the "use 
OLD adaptec drivers. As advised in the kernel make notes on 2.4.5, disabling tagged queing on your scsi controller may solve your install problems, 
without having to do a new kernel install.
Comment 7 Michael Hall 2001-05-30 15:25:03 EDT
does this mean you are using the install floppy SGI made ?
I did try the install floppy that SGI made.  However, I thought that it may be 
the problem so I created the install floppy from the RH CD.
Comment 8 Jeff Hazard 2001-05-30 18:18:49 EDT
The 2.4.5 kernel appears to fix MY adaptec problems. As to installing RH 7.1,  I  don't know how to make an install floppy for 7.1 with the
2.4.5 kernel and modules. RedHat may have to do it or give me instructions. 
Using  2.2.19 on RH 7.0, I could compile the  2.4.2, 2.4.3 and 2.4.4 kernels, but never boot cause of the Adaptec SCSI bus hanging.
I was using an older 7.0 partition to compile and test with. The 2.4.5 kernel nas been working great with both a Mandrake 8.0 installation and
the 7.0 Redhat Installation.

All you can try is turning off tagged queing on your SCSI card until a boot disk with the 2.4.5  kernel is tested and available.
Comment 9 Michael Hall 2001-05-31 10:05:46 EDT
>All you can try is turning off tagged queing on your SCSI card until a boot 
>disk with the 2.4.5  kernel is tested and available

I looked this morning and did not see anything in the SCSI Cofiguration utility 
about tagged queing.  Where is that setting at in the SCSI config?  On my SCSI 
card I hit <ctrl>-<a> to enter the SCSI setup information.
Comment 10 Michael Hall 2001-06-01 14:32:02 EDT
Anyone have any other ideas about this.  Has any progress been made on this 
install problem?  I see that I am not the only one.  Would like to get my 
system up.

Comment 11 IO ERROR 2001-06-11 02:29:02 EDT
I've got a Tyan S1598C2 motherboard and Adaptec 2940U2W SCSI card.  I am 
having identical problems with the installer and the 2.4.2 kernel.  "expert 
noprobe" didn't work for me.

I "upgraded" from 7.0 to 7.1 the hard way:  ran rpm -U --force on all the RPMS 
on both CDs.  (I always install everything anyway...)  Installed the 
2.4.2-i586 kernel, when it boots, system hangs at Freeing kernel memory... 64k 
freed.  Next line expected is "INIT: version 2.78 booting" never appears.  I 
get SCSI host timeout errors instead.  SMP kernel had similar results.

I finally got the system back by installing the 2.2 kernel from 7.0, then 
promptly compiled 2.4.5 with the OLD Adaptec SCSI driver built into the kernel 
and tagged command queuing disabled, and that is how it is running today.
Comment 12 Alessandro Pisani 2001-06-17 08:54:29 EDT
I have the same problem with AIC 29160N, Seagate SCSI160 18gb hd, SCSI CDROM,
on an ASUS A7V-E (VIA82C686x Chipset) motherboard with AMD Athlon cpu.
RedHat 7.1 installer hangs loading aic7xxx driver, getting me to a kernel
panic screen. AFAIK, problem had been solved in later 2.4.x kernels (lastest
prepatch of 2.4.4 and then 2.4.5), but are there any kind of workaround for
the kernel used in the RH7.1 installer ? or there is a way to bypass
this problem ?

Thanks in advance,
Alessandro Pisani <alextxm@tin.it>
Comment 13 Need Real Name 2001-06-25 12:45:01 EDT
I am experiencing similar problems on a FIC VA-503+ K6-3/450.  I have a 
ST34501W and a XM-6201 CD.  The problems started as a hang on boot after 
upgrading the kernel from 2.2.19 to 2.4.[123].  Contact with the aic7xxx 
maintainer and several driver versions provided no change in the symptoms, 
which were a complete system hang (no KB, hard reset required) after the 
xxx instructions downloaded message.  

Subsequently, I tried a Redhat 7.1 install which hung when the 'loading 
aic7xxx driver' message displayed.  A hard reset was required, KB did not 
work.  I plan to disable wide negotiation and try an upgrade to bios 2.20.
Comment 14 Need Real Name 2001-06-25 20:31:33 EDT
I tried disabling wide negotation as mentioned in a Usenet article
with no effect on the hang. I also upgraded the adapter BIOS to
2.20 with no effect. The AHA-2940UW has been tried in all three
PCI slots and in combination with the other PCI cards (Matrox Mil2
and 3Com 3c905cx-tx). This board uses a MVP3 chipset and is set to
'non PNP OS'.

This bug should have the severity adjusted to high and the priority
set to high also, IMHO. What should be done to try and resolve the
Comment 15 Need Real Name 2001-08-05 18:26:59 EDT
I got the same problem. I could not install RH7.1 neither with my 2940U2W card (Bios 2.11) nor with my 29160 card. The install program simply hangs no matter what 29xxx driver I tried. With RH7.0 I had more luck, at least I could install the OS but under certain load conditions (copying big files or install programs) I get SCSI Timeout and Reset messages and I have to reset the server.

Honestly I am bit disapointed of Redhat because all what they are offering to fix the problem is this bug repoprt page and links to aic99xxx driver source pages. I personally don4t have the time to experiment days and days and just want to install RH and concentrate my work to the aplication.

Comment 16 Need Real Name 2001-08-09 09:49:40 EDT
I am also experiencing this problem. And I think we've all waited long enough 
for Redhat to provide a bug-free installer. Their lack of support for those of 
us who are suffering through this mess makes Microsoft look pretty good, by 
comparison. You've got my money, Redhat. Now when are you going to give me what 
I paid for?
Comment 17 Buckley 2001-08-16 01:22:10 EDT
Hey DL. 
Here is one more for you.
'Loading aic7xxx driver....' also hangs for my VALinux boxes with the following:
I have tried to upgrade two of the four boxes (from 6.2) with identical results
(so I assume the other two will do the same thing).
Would like to hear from anyone with a working work-around for this upgrade.
Comment 18 Doug Ledford 2001-08-23 19:52:23 EDT
There are a lot of unrelated reports on this single but report (aka, a bunch of
"Me Too" reports that aren't really the same as the original one).

First, to buckley@menacefx.com, your problem has been fixed for ages and there
is even a writeup about it in the 7.1 gotchas page.  Go to bug #29555 to see the
full report.

To edt, I've addressed your issue under another bug report.

To mwhall, you tried using a Buslogic controller instead of an aic7xxx
controller and it still failed.  I also noticed that the SCSI controller is
assigned IRQ 15.  I think you have an IRQ conflict that is causing an IRQ storm
(and on UP machines, IRQ storms are fatal, they result in hard locks that
require you to hit the reset button).  I would try either disabling or enabling
your secondary IDE interface and any possible USB interfaces in your motherboard
BIOS to see if that makes a difference.

To jdhazard and error@underground.net, since disabling tagged queueing has
solved your problem, you need updates to the firmware on your SCSI drives.  The
Adaptec's driver has had fine tagged queueing for years now, but we didn't
enable it by default in the past because of broken drives.  Evidently, your
drives are still broken.

To alextxm, trying booting the install disk with the option noprobe and then
when selecting drivers you should be able to select the New Adaptec scsi driver
(at the middle of the list if I remember correctly) to see if that helps you out.

To the remaining people, there are absolutely no details in your entries that I
can use to diagnose your problem.  If your problems aren't solved by following
the other advice I've given in this update, then don't add more to this bug
report, open a new bug report with complete details of your failure so that I
can diagnose what's going on with your systems.
Comment 19 Alessandro Pisani 2001-08-26 13:00:18 EDT
To: dledford@redhat.com 
I tried using the noprobe option, as you suggested.
I was able to successfully complete the install process only selecting the OLD
adaptec driver, the NEW one hangs while loading.  After the successfull install,
I tried compiling a clean 2.4.7 kernel from sources (not RedHat SRPM) and then
booting using the new adaptec driver: I had no success.
I tried with 2.4.7 using aic7xxx_old and it booted correctly. The same happens
using RH stock kernel 2.4.2-2. Summing up, the trick of the "noprobe" option in
the install process worked fine for me...with the old driver. Thanks!
Btw, using 29160N with the old driver gives me some timeout errors (I have a
SCSI160 HD and a normal SCSI2 CDROM, both connected to 29160N controller) which
cause me to reset the pc.
I'll do more tests downgrading the trasfer-rate through SCSIboard-BIOS... does
anyone know if this could help ?

PS: Is anyone aware of any Adaptec response/bugfix for these problems with their
new driver ?!?
Comment 20 Doug Ledford 2001-08-27 10:31:10 EDT
alextxm:  Good to hear.  Since your system is working with the old driver and
not the new driver, then you really need to be in contact with Justin Gibbs
<gibbs@btc.adaptec.com> who can help work through whatever problems your machine
has with the new driver (and to answer your question, yes, Adaptec has been very
responsive on fixing bugs in their new driver).  However, the fact that my
driver has occasional reset issues on your machine may mean that there is more
to it than simply a difference between the drivers.  It may be that there is
something wrong on your SCSI bus that my driver isn't as sensitive to as
Justin's driver.  Especially if turning down the bus speed helps the problem out
I would strongly suspect that there are either cabling or termination problems
in the SCSI bus.  Justin, is there any quick, easy, and complete guide to
termination on Adaptec cards that you know of, or is this something that needs
written (probably would have saved me over a hundred hours in the last year
alone to have a complete and easy to understand guide to this issue)?
Comment 21 Alessandro Pisani 2001-08-27 12:08:32 EDT
to: dledford@redhat.com
Thanks, I'll contact Justin Gibbs for my issues with the new driver.
Today I spent some time testing the old driver (yours) : I lowered max transfer
rate to 80MB/s via the SCSI bios, and now all runs okay (i have scsi160 (hd) and
scsi2 (cdrom) devices). Btw the new driver still won't work at all: I'll
investigate this with Mr Gibbs.
thanks and bye
Comment 22 Lynn Wheelwright 2001-08-28 19:24:42 EDT
I too, have run into the dreaded AIC7xxx driver loading hangup at install of RH7.1.
Configuration: Motherboard, MSI6347 with SCSI on the board, AMD 900 MHz Tbird CPU.
1 40 GB ide disk
2 4 GB scsi disks
1 CDRW (scsi)
1 DVD-RAM (scsi).

The installer boots of the scsi cdrw drive.  Press enter to install and it hangs trying to load the scsi driver.

At one point, I tried an install with only the cdrw drive hooked up (first try).  It loaded the driver, but I had 
an ide problem that would not let me complete the install (an 80 GB drive died).  Point me at more explicit
instructions, and I will be happy to provide feedback.
Comment 23 Doug Ledford 2001-08-29 10:38:31 EDT
lynnw:  Try doing the install with the DVD-RAM disconnected again (since it
worked last time except your IDE drive died, it should work again).  Get the
install completed, boot the new system up and make sure everything is OK.  Once
you know everything it good, then reconnect the DVD-RAM drive and if it starts
flaking out, then please open a new bug report with the specific aic7xxx error
messages you get when the DVD-RAM drive is corrected.  If, instead, it works OK,
then open a new bug report, but don't list the problem as being aic7xxx related
(because it won't be), instead list the problem as the kernel locking when 2
different CD drives are present during an install (a previously seen condition
that we haven't figured out entirely yet that I'm aware of).
Comment 24 Need Real Name 2001-09-12 13:36:49 EDT
I tried installing Redhat 7.0 on my VA Linux machine which has SCSI. Everything 
worked fine(It installs the aic7xxx driver well). But when I try 
installing/upgrading the same machine with Redhat 7.1 it hangs. 

Any solution for this yet ???
Comment 25 Doug Ledford 2001-09-19 10:06:27 EDT
To raju:

Your problem is already well documented (and the fix presented) in bug #29555.
Comment 26 Doug Ledford 2004-05-12 13:33:28 EDT
This is an ancient bug on a no longer existing product.  I'm closing
this out.

Note You need to log in before you can comment on or make changes to this bug.