Bug 41851 - ypmatch not handling services correctly
Summary: ypmatch not handling services correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: yp-tools (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-22 16:02 UTC by Mike Sklar
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 15:44:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Sklar 2001-05-22 16:02:41 UTC
Description of Problem:

ypmatch does not work properly for checking services. Even though the /var/yp/nicknames is setup to to lookup byname and not bynumber.



How Reproducible:



asdfjkl$ ypmatch nntp hosts

Can't match key nntp in map hosts.byname. Reason: No such key in map



asdfjkl$ grep services /etc/nsswitch.conf /var/yp/nicknames

/etc/nsswitch.conf:services:   nis files

/var/yp/nicknames:services      services.byname



Steps to Reproduce:

1. bind to a yp server

2. make sure you /etc/nsswitch.conf and /var/yp/nicknames looks like mine.

3. ypmatch <servicename> services



Actual Results:





Expected Results:



Fix ypmatch code to do correct lookups for byname, not just bynumber.



Additional Information:

Comment 1 Alexander Larsson 2002-03-25 23:47:01 UTC
Fixed in ypserv 2.2-5.


Note You need to log in before you can comment on or make changes to this bug.