Bug 41852 - /etc/lilo.conf permission (and boot password)
/etc/lilo.conf permission (and boot password)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 12:07 EDT by Jan "Yenya" Kasprzak
Modified: 2007-03-26 23:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 10:48:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2001-05-22 12:07:18 EDT
I suggest to change the default permission of /etc/lilo.conf to be 0600
instead
of 0644, because /sbin/lilo complains when user tries to use the boot
password
in lilo.conf with default permission.
I would also appreciate if Red Hat Linux installer can set up the boot
password
for new users (and add the "restricted" keyword to lilo.conf).
Comment 1 Daniel Roesen 2001-05-31 10:48:30 EDT
Good idea IMHO. Thought of that but forgot to file in Bugzilla...
Comment 2 Jeremy Katz 2002-06-04 02:26:08 EDT
The installer will allow you to setup grub passwords now and will properly set
the permissions on the file if you set up a password.  Also, anaconda/up2date
will preserve a password and permissions if they are already set

Note You need to log in before you can comment on or make changes to this bug.