Bug 41859 - /usr/lib/librpm.so.0: undefined symbol: fpHashFunction
Summary: /usr/lib/librpm.so.0: undefined symbol: fpHashFunction
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-22 16:50 UTC by Vladimir Kondratiev
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 16:50:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vladimir Kondratiev 2001-05-22 16:50:24 UTC
Description of Problem:
In rpm packege rpm-4.0.3-0.22, in /usr/lib/librpm.so.0, symbol
fpHashFunction is missing. Due to this, 'kpackage' and 'gnorpm' can not start.

How Reproducible:
Always

Steps to Reproduce:
1. run 'kpackage' or 'gnorpm'

Additional Information:
rpm -qf `which kpackage`
kdeadmin-2.2-0.alpha1.1
rpm -qf `which gnorpm`
gnorpm-0.96-1

Comment 1 Jeff Johnson 2001-05-22 16:53:15 UTC
Yup, you're running unreleased development code, caveat emptor.

Either use rpm-4.0.2 or recompile kpackage/gnorpm from sources.


Comment 2 Vladimir Kondratiev 2001-05-22 17:41:31 UTC
No one of the packages mentioned can be rebuild. I filled separate bugs for
these packages, but I suppose root cause is rpm.
see bugs 41860 and 41861

Comment 3 Vladimir Kondratiev 2001-05-30 12:09:27 UTC
bug is still there:
[]# rpm -q kdeadmin rpm
kdeadmin-2.2-0.alpha2.1
rpm-4.0.3-0.26
[]# kpackage 
kpackage: error while loading shared libraries: /usr/lib/librpm.so.0: undefined
symbol: fpHashFunction

Comment 4 Jeff Johnson 2001-05-30 12:22:15 UTC
Yes the bug will persist until you relink kpackage against rpm-4.0.3
libraries.

Have you tried the kdeadmin package at
ftp://ftp.rpm.org/pub/rpm/test-4.0.3-ROLLBACKS?

Otherwise, you need to use rpm-4.0.2, not rpm-4.0.3 ...

Comment 5 Vladimir Kondratiev 2001-05-30 13:47:55 UTC
You are right, if I rebuild kdeadmin from sources, 'kpackage' do work.
The only question remains - why binary package on rawhide ftp do not corresponds
to the source package, but this is question for kdeadmin package itself.


Note You need to log in before you can comment on or make changes to this bug.