Bug 418621 - Valgrind reports invalid reads in python
Valgrind reports invalid reads in python
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: 418931 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-12-10 13:42 EST by Kjartan Maraas
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-07 08:57:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
valgrind log (140.62 KB, text/plain)
2007-12-10 13:52 EST, Kjartan Maraas
no flags Details
valgrind log (89.15 KB, text/plain)
2008-01-07 06:17 EST, Kjartan Maraas
no flags Details

  None (edit)
Description Kjartan Maraas 2007-12-10 13:42:08 EST
Description of problem:

I get this segfault when running rhythmbox:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7fc5720 (LWP 3129)]
0x02514c61 in malloc_consolidate (av=0x2603120) at malloc.c:4834
4834	            unlink(p, bck, fwd);
(gdb) bt
#0  0x02514c61 in malloc_consolidate (av=0x2603120) at malloc.c:4834
#1  0x02516d8d in _int_malloc (av=0x2603120, bytes=1048) at malloc.c:4166
#2  0x02518b7b in __libc_malloc (bytes=1048) at malloc.c:3553
#3  0x00feea56 in IA__g_malloc (n_bytes=1048) at gmem.c:131
#4  0x0100366b in IA__g_slice_alloc (mem_size=1048) at gslice.c:824
#5  0x00bdf519 in pango_script_iter_new (text=0x92ac2d8 "Adam Richman (1)", 
    length=16) at pango-script.c:130
#6  0x00bcdb8f in itemize_state_init (state=0xbfe84be0, 
    context=<value optimized out>, text=<value optimized out>, 
    base_dir=PANGO_DIRECTION_LTR, start_index=0, length=16, attrs=0xb5db2900, 
    cached_iter=0xb5ddf4c0, desc=0x0) at pango-context.c:852
#7  0x00bcea2b in pango_itemize_with_base_dir (context=0x903d950, 
    base_dir=PANGO_DIRECTION_LTR, text=0x92ac2d8 "Adam Richman (1)", 
    start_index=0, length=16, attrs=0xb5db2900, cached_iter=0xb5ddf4c0)
    at pango-context.c:1423
#8  0x00bd7c04 in pango_layout_check_lines (layout=0x92d3db0)
    at pango-layout.c:3618
#9  0x00bd8da7 in pango_layout_get_extents_internal (layout=0x92d3db0, 
    ink_rect=0x0, logical_rect=0xbfe84f3c, line_extents=0x0)
    at pango-layout.c:2311
#10 0x00722cce in get_size (cell=0x8ca6398, widget=0x8c38d08, cell_area=0x0, 
    layout=0x92d3db0, x_offset=0x0, y_offset=0x0, width=0xbfe8503c, 
    height=0xbfe85040) at gtkcellrenderertext.c:1540
---Type <return> to continue, or q <return> to quit---
#11 0x00722fb5 in gtk_cell_renderer_text_get_size (cell=0x8ca6398, 
    widget=0x8c38d08, cell_area=0x0, x_offset=0x0, y_offset=0x0, 
    width=0xbfe8503c, height=0xbfe85040) at gtkcellrenderertext.c:1606
#12 0x00719d93 in IA__gtk_cell_renderer_get_size (cell=0x8ca6398, 
    widget=0x8c38d08, cell_area=0x0, x_offset=0x0, y_offset=0x0, 
    width=0xbfe8503c, height=0xbfe85040) at gtkcellrenderer.c:508
#13 0x0099d85e in IA__gtk_tree_view_column_cell_get_size (
    tree_column=0x8caceb0, cell_area=0x0, x_offset=0x0, y_offset=0x0, 
    width=0xbfe850f4, height=0xbfe850f0) at gtktreeviewcolumn.c:2606
#14 0x00980817 in validate_row (tree_view=0x8c38d08, tree=0x8ccaae8, 
    node=0x92bc480, iter=0xbfe85280, path=0x92f57d8) at gtktreeview.c:5609
#15 0x009817bb in validate_visible_area (tree_view=0x8c38d08)
    at gtktreeview.c:5924
#16 0x00982761 in do_presize_handler (tree_view=0x8c38d08)
    at gtktreeview.c:6237
#17 0x009828ce in presize_handler_callback (data=0x8c38d08)
    at gtktreeview.c:6259
#18 0x00ae88ff in gdk_threads_dispatch (data=0x92c9270) at gdk.c:470
#19 0x00fe5541 in g_idle_dispatch (source=0x903d068, callback=0, 
    user_data=0x92c9270) at gmain.c:4132
#20 0x00fe710c in IA__g_main_context_dispatch (context=0x8a975f8)
    at gmain.c:2061
#21 0x00fea54f in g_main_context_iterate (context=0x8a975f8, block=1, 
---Type <return> to continue, or q <return> to quit---
    dispatch=1, self=0x89cc410) at gmain.c:2694
#22 0x00fea8f9 in IA__g_main_loop_run (loop=0x923cb38) at gmain.c:2898
#23 0x008283ca in IA__gtk_main () at gtkmain.c:1163
#24 0x0805f7ed in main (argc=Cannot access memory at address 0x1
) at main.c:340

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Kjartan Maraas 2007-12-10 13:52:16 EST
Created attachment 283071 [details]
valgrind log

Here's a valgrind log. Somehow it didn't crash when I ran it in valgrind so
maybe there's a race here somewhere?
Comment 2 Bastien Nocera 2007-12-10 17:23:20 EST
*** Bug 418931 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2007-12-17 14:39:57 EST
I upgraded my whole machine to rawhide, and I can't reproduce the problem here...
Comment 4 Kjartan Maraas 2007-12-17 15:13:20 EST
You mean you don't see invalid reads in valgrind logs or that it doesn't crash?
Comment 5 Bastien Nocera 2007-12-17 16:21:07 EST
Doesn't crash for me. I haven't tried running it under valgrind, as most of the
invalid reads are actually from python, not from us.

Tried disabling all the plugins? Any other errors on the command-line?
Comment 6 Stewart Adam 2007-12-17 21:10:31 EST
When I was having this problem I had only applied half the available updates
from the repo since there were a few broken deps - Now that I've updated all
packages it seems to be fine. Maybe there was a missing Requires on a pacakge
somewhere along the way.
Comment 7 Kjartan Maraas 2008-01-03 07:17:41 EST
I don't see any crashes either, but I do still see the invalid reads when
running it in valgrind. They all come from python related code it seems
Comment 8 Bastien Nocera 2008-01-07 05:19:34 EST
Cool. I'll reassign this to Python, as they should fix the valgrind errors there.

The valgrind log is in comment #1.
Comment 9 Kjartan Maraas 2008-01-07 06:16:36 EST
Changing the summary to reflect reality. Adding a log from running python and a
small script under valgrind.
Comment 10 Kjartan Maraas 2008-01-07 06:17:30 EST
Created attachment 290944 [details]
valgrind log

python run with debuginfo installed
Comment 11 James Antill 2008-01-07 11:28:03 EST
 See the Misc/README.valgrind and Misc/valgrind-python.supp file in the python
tarball, we probably should package these as part of python-devel ... I'll do
that for Fed-9. And I've put them on my people page now, so it's easier for you:

 Moving this bug back though.
Comment 12 Bastien Nocera 2008-03-28 10:59:38 EDT
Kjartan, any errors with that python helper for valgrind?
Comment 13 Kjartan Maraas 2008-04-07 08:57:31 EDT
I'll close this here and file a bug upstream if I find any problems.

Note You need to log in before you can comment on or make changes to this bug.