Bug 418651 - Forms: Instead of x sign, $ sign appears in checkboxes
Summary: Forms: Instead of x sign, $ sign appears in checkboxes
Status: CLOSED DUPLICATE of bug 468565
Alias: None
Product: Fedora
Classification: Fedora
Component: evince   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-10 19:12 UTC by Martin Jürgens
Modified: 2010-04-09 08:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 11:21:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Evince displays $ signs in checkboxes rather than checks. (6.18 KB, image/png)
2009-03-31 03:05 UTC, Andy Haninger
no flags Details

Description Martin Jürgens 2007-12-10 19:12:24 UTC
Please describe the problem:
In some forms, when ticking a checkbox, a $ sign appears instead of a x or a
tick.

Steps to reproduce:
1. Open
http://www.sparda-west.de/lnkcnt.php?et=6pV&url=/pdf/west_fsa2007.pdf&lnkname=PDF+-+Freistellungsauftrag+f%26uuml%3Br+Kapitalertr%26auml%3Bge
2. Tick the box "ledig"
3. 


Actual results:
A dollar sign appears in the checkbox

Expected results:
A tick or a x should appear in the checkbox

Does this happen every time?
Yes!

Other information:


$ fc-match ZapfDingbats
DejaVuLGCSans.ttf: "DejaVu LGC Sans" "Book"

Comment 1 Martin Jürgens 2008-06-14 15:45:36 UTC
Issue still exists as of Fedora 9. I would be grateful if it was fixed.

Comment 2 Martin Jürgens 2008-09-03 18:57:37 UTC
any updates on this?

Comment 3 Andy Haninger 2009-03-31 03:01:47 UTC
For what it's worth, this behavior exists outside of Fedora. I'm running Slackware 11 and I get the $ signs instead of check marks on the Ohio 2008 income tax form. You can download the fillable version of the form at <http://tax.ohio.gov/documents/forms/ohio_individual/individual/2008/PIT_1040EZ_2008_SFI.pdf>.

In cases like this (taxes - one of the two certainties in life) I'd say that the priority should be somewhat higher than "low". Of all characters to appear randomly on my tax return, why does it have to be a dollar sign!?

I'll add a screenshot for good measure.

Comment 4 Andy Haninger 2009-03-31 03:05:15 UTC
Created attachment 337269 [details]
Evince displays $ signs in checkboxes rather than checks.

Comment 5 Andy Haninger 2009-03-31 03:11:32 UTC
I should also mention that I'm running evince 2.26.0 using poppler 0.10.5 with cairo.

Comment 6 Martin Jürgens 2009-05-14 11:06:34 UTC
well. any updates?

Comment 7 Martin Jürgens 2009-05-14 11:21:52 UTC

*** This bug has been marked as a duplicate of bug 468565 ***

Comment 8 Thomas Moschny 2010-04-09 08:25:39 UTC
Not sure if that is really a duplicate of bug 468565, as I see two different problems: In some documents boxes can't be checked at all, in other documents a '$' is shown instead of an 'X'.


Note You need to log in before you can comment on or make changes to this bug.