Bug 41868 - (SOUND OPL3SA2)opl3sa2 sound driver problems.
Summary: (SOUND OPL3SA2)opl3sa2 sound driver problems.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-22 18:58 UTC by Jason A. Smith
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:39:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason A. Smith 2001-05-22 18:58:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-ac12-smp i686)

Description of problem:
The opl3sa2 driver included with recent kernels is partially broken.  It
plays sounds just fine, but I cannot record from the line-in (where I have
a radio card connected).

I recently upgraded to RedHat 7.1, before this I was using an updated 6.2
system with a 2.4 kernel.  Even before updating to 7.1 I noticed that the
opl3sa2 driver was heavily modified somewhere around 2.4.1 to 2.4.2 which
broke the recording from the input line.  I am pretty sure it is the driver
since I booted back into an older kernel that I still have and it works
fine.

One odd thing, after booting into 2.4.2, a simple reboot into the older
working kernel does not work, I have to completely power down the computer
so I assume that the driver is messing with the ISA-PnP settings on the
card that get reset when I power it off.

Another minor problem is that the interface to the master volume control
must have changed in the new driver because it is not controlable with
aumix or the gnome mixer applet anymore.


How reproducible:
Always

Steps to Reproduce:
I just boot into the 2.4.2-2smp kernel and try to record from the line in
like so:

# Set the recording to the input line:
aumix -l R

# Create a 60 sec wav file reading directly from the sound device:
ecasound -f:16,2,44100 -t:60 -i:/dev/dsp -o:out.wav

# Or use esd to read (both fail):
esdrec | ecasound -b:64 -f:16,2,44100 -t:60 -i:stdin -o:out.wav


Additional info:

Before updating to 7.1, I tried the new opl3sa2 driver in the post 2.4.1
kernels and would see this message in my log when I tried to record:

kernel: Sound: DMA (input) timed out - IRQ/DRQ config error?

I don't see that with your 2.4.2-2 kernel though.  Just let me know if you
need any more info.

Comment 1 Jason A. Smith 2001-09-07 20:30:54 UTC
Has there been any progress on this or any other confirmation?  I haven't tried
building any new kernels yet, but I have noticed that the
linux/drivers/sound/opl3sa2.c driver in the official Linus kernels has not
changed since around 2.4.2 when this broke on me.  Is there a sound maintainer
that I should contact about possibly fixing this?

~Jason


Comment 2 Bugzilla owner 2004-09-30 15:39:01 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.