Bug 41869 - RC1 release of ia64 RH may not install
RC1 release of ia64 RH may not install
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-05-22 15:00 EDT by Bryan Leopard
Modified: 2005-10-31 17:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-30 10:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-05-22 15:00:44 EDT
The RC1 release incorrectly sets up the partition table. This results in  
not being able to boot the OS after install.

When the driver loads it shows 3 partitions as expected. However, after 
moving the drive to another system and running fdisk shows a corrupted 
partition table. The / filesystem can be mounted but the EFI partition 
Comment 1 Bryan Leopard 2001-05-22 15:01:34 EDT
Create the partitions using the Beta 1 release, then install RC1. Or, on a disk 
that already has the desired partitons use disk druid to set mount points only.
Comment 2 Bill Nottingham 2001-05-22 16:34:20 EDT
Don't use fdisk. Disk Druid uses EFI GPT partitioning. This should work
fine with the firmware, AFAIK.
Comment 3 Bryan Leopard 2001-05-22 16:44:03 EDT
The partition table is corrupt using disk druid or fdisk. We tried both with 
the same results. I noticed that the partition created with druid was type EFI 
GPT, however it also showed me a number of blocks which greatly exceeded the 
capacity of my 9GB drive.
So just using disk druid rather than fdisk does not work.
Comment 4 Bill Nottingham 2001-05-23 11:09:37 EDT
This wouldn't happen to have been attached to a smartarray in the ia64, was it?
I don't think you can do that.
Comment 5 Bryan Leopard 2001-05-23 16:58:06 EDT
Compaq's system has a ROC embedded.  This even happened on a SCSI card.
Notes from one of my engineers:
I tested with a blank disk hooked to the qlogic controller.  The same thing 
happens.  Thier installer is NOT updating the partition table on the disk. 

If you run fdisk /tmp/sda just before the system reboots (this is where the OS 
is installed) it said I still had an invalid partion table.  
The problem is that fdisk and diskdruid are incorrectly setting up the 
partition tables.  The problem is seen if you use a clean disk drive that has 
not been sliced up yet.  If you have a drive that is already set up, then you 
don't see the problem. 

This worked with beta3.  Workarounds are to go to a i386 system and setup 
partition table with i386 software or run beta 3 to setup partitions and then 
load RC1.  

This is a must fix.  
Comment 6 Bill Nottingham 2001-05-23 18:25:36 EDT
As stated before, fdisk does not read the partition table format created
by disk druid; it doesn't matter when during the install you run it. You can
read the GPT partition table with
- the kernel
- parted
- disk druid
Comment 7 Bryan Leopard 2001-05-24 11:00:11 EDT
Can you get Mike.miller@compaq.com added to the permissions of this bug?  Or 
talk to him directly?  He is the engineer with the most information for you to 
get this bug resolved.

Comment 8 Bill Nottingham 2001-05-24 11:32:46 EDT
He should be on the CC: list now.
Comment 9 Bill Nottingham 2001-05-30 10:57:37 EDT
FYI: we did manage to reproduce this in-house yesterday, and are now
working towards a fix.
Comment 10 Bill Nottingham 2001-05-30 15:55:56 EDT
A fix has been made available on the beta site, and should be in the next

Note You need to log in before you can comment on or make changes to this bug.