Bug 418761 - Possible mis-ordering of messages in perftest.
Possible mis-ordering of messages in perftest.
Status: CLOSED DUPLICATE of bug 412551
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Alan Conway
Kim van der Riet
Depends On:
  Show dependency treegraph
Reported: 2007-12-10 15:35 EST by Alan Conway
Modified: 2007-12-11 09:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-11 09:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2007-12-10 15:35:57 EST
Description of problem:

Race in perftest indicates messages may be out of sequence. Not clear if this 
is a problem with the broker, the client or the test itself. Run in a loop as

[aconway@file-18 tests]$ while  ./perftest --count 100000 -s ; do true; done

Controller exception: Bad data, expecting double: Out-of-sequence messages

Version-Release number of selected component (if applicable):
svn revision 603037

How reproducible:

In an optimized build on file-18 (an 8 core server) it happens reliably within
10 runs or so. I have not reproduced it on any other box or with a debug build.

Additional info:

The error is caused by the controller receiving a non-numerical "out of order"
report from a subscriber.
Comment 1 Kim van der Riet 2007-12-11 09:56:02 EST

*** This bug has been marked as a duplicate of 412551 ***

Note You need to log in before you can comment on or make changes to this bug.