Bug 418771 - should /etc/pki/tls/certs/ca-bundle.crt not be the default one used?
should /etc/pki/tls/certs/ca-bundle.crt not be the default one used?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 423551 450986 450987
  Show dependency treegraph
 
Reported: 2007-12-10 15:36 EST by Patrick C. F. Ernzer
Modified: 2008-06-12 00:00 EDT (History)
0 users

See Also:
Fixed In Version: openssl-0.9.8g-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 12:21:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2007-12-10 15:36:56 EST
Description of problem:
it seems that when I use "openssl s_client -connect ..." I need to explicitly
specify "-CAfile /etc/pki/tls/certs/ca-bundle.crt"

I was expecting that one to be used by default, but maybe my expectations are
just wrong

Version-Release number of selected component (if applicable):
openssl-0.9.8b-17.fc8

How reproducible:
always

Steps to Reproduce:
1. use claws-mail
2. get a new certificate from your email server
3. be completely paranoid that a cert that claims to be signed by verisign fails
verification with "unable to get local issuer certificate"
4. debug
  
Actual results:
it turns out that
  openssl s_client -connect mail.kolumbus.fi:993
will fail with the error above, while
  openssl s_client -CAfile /etc/pki/tls/certs/ca-bundle.crt -connect
mail.kolumbus.fi:993
tells me "Verify return code: 0 (ok)"

Expected results:
I would expect not to have to manually specify the system-wide default
ca-bundle, and it seems claws-email has the same expectations.

Additional info:
Comment 1 Tomas Mraz 2007-12-12 14:09:50 EST
The openssl s_client case is a bug in openssl - note that openssl s_client
-CApath whatevernonexistent -connect .... will work fine.

But I have looked at the claws-mail sources and this bug doesn't apply there and
it apparently does some certificate chain verification on its own so this bug
should be cloned for claws-mail if you want to have it fixed there too.
Comment 2 Tomas Mraz 2007-12-13 12:21:31 EST
s_client/s_server will be fixed now. But claws-mail has to be fixed on its own.
Comment 3 Patrick C. F. Ernzer 2008-05-16 11:26:52 EDT
confirm this is fixed in openssl-0.9.8g-6.fc9.i686

Note You need to log in before you can comment on or make changes to this bug.