Bug 418971 - hang when getting password / accessing keyring
hang when getting password / accessing keyring
Status: CLOSED DUPLICATE of bug 416991
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 18:03 EST by Kjartan Maraas
Modified: 2007-12-21 12:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 12:18:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2007-12-10 18:03:24 EST
Description of problem:

I see evolution hanging from time to time. Attaching gdb gives the following
backtrace:

(gdb) bt
#0  0x0012d402 in __kernel_vsyscall ()
#1  0x0040152b in read () from /lib/libpthread.so.0
#2  0x0120afd0 in read_all (fd=35, buf=0xb2dd03a8 "", len=4) at
/usr/include/bits/unistd.h:45
#3  0x0120c398 in run_sync_operation (buffer=0xbfdd7ab4,
receive_buffer=0xbfdd7aa0) at gnome-keyring.c:652
#4  0x0120c80e in gnome_keyring_find_items_sync
(type=GNOME_KEYRING_ITEM_NETWORK_PASSWORD, attributes=0xada51cb0, 
    found=0xbfdd7b38) at gnome-keyring.c:2148
#5  0x0036c466 in ep_get_password (msg=0xae20ff00) at e-passwords.c:702
#6  0x0036bfc5 in ep_idle_dispatch (data=0x0) at e-passwords.c:237
#7  0x03099541 in g_idle_dispatch (source=0xb2c4ee00, callback=0x4,
user_data=0x0) at gmain.c:4132
#8  0x0309b10c in IA__g_main_context_dispatch (context=0x9ec94c8) at gmain.c:2061
#9  0x0309e54f in g_main_context_iterate (context=0x9ec94c8, block=1,
dispatch=1, self=0x9ea26c8) at gmain.c:2694
#10 0x0309e8f9 in IA__g_main_loop_run (loop=0x9ef0b50) at gmain.c:2898
#11 0x00898813 in bonobo_main () at bonobo-main.c:311
#12 0x0805e6f1 in main (argc=2, argv=0xbfdd7ee4) at main.c:602
#13 0x0747b390 in __libc_start_main (main=0x805e340 <main>, argc=2,
ubp_av=0xbfdd7ee4, init=0x805eee0 <__libc_csu_init>, 
    fini=0x805eed0 <__libc_csu_fini>, rtld_fini=0x11e940 <_dl_fini>,
stack_end=0xbfdd7edc) at libc-start.c:220
#14 0x0804f671 in _start ()

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2007-12-10 18:04:19 EST
And here's one from all threads:

(gdb) c
Continuing.

Program received signal SIGINT, Interrupt.
[Switching to Thread 0xb7f90710 (LWP 12622)]
0x0012d402 in __kernel_vsyscall ()
(gdb) bt
#0  0x0012d402 in __kernel_vsyscall ()
#1  0x0040152b in read () from /lib/libpthread.so.0
#2  0x0120afd0 in read_all (fd=35, buf=0xb2dd03a8 "", len=4) at
/usr/include/bits/unistd.h:45
#3  0x0120c398 in run_sync_operation (buffer=0xbfdd7ab4,
receive_buffer=0xbfdd7aa0) at gnome-keyring.c:652
#4  0x0120c80e in gnome_keyring_find_items_sync
(type=GNOME_KEYRING_ITEM_NETWORK_PASSWORD, attributes=0xada51cb0, 
    found=0xbfdd7b38) at gnome-keyring.c:2148
#5  0x0036c466 in ep_get_password (msg=0xae20ff00) at e-passwords.c:702
#6  0x0036bfc5 in ep_idle_dispatch (data=0x0) at e-passwords.c:237
#7  0x03099541 in g_idle_dispatch (source=0xb2c4ee00, callback=0x4,
user_data=0x0) at gmain.c:4132
#8  0x0309b10c in IA__g_main_context_dispatch (context=0x9ec94c8) at gmain.c:2061
#9  0x0309e54f in g_main_context_iterate (context=0x9ec94c8, block=1,
dispatch=1, self=0x9ea26c8) at gmain.c:2694
#10 0x0309e8f9 in IA__g_main_loop_run (loop=0x9ef0b50) at gmain.c:2898
#11 0x00898813 in bonobo_main () at bonobo-main.c:311
#12 0x0805e6f1 in main (argc=2, argv=0xbfdd7ee4) at main.c:602
#13 0x0747b390 in __libc_start_main (main=0x805e340 <main>, argc=2,
ubp_av=0xbfdd7ee4, init=0x805eee0 <__libc_csu_init>, 
    fini=0x805eed0 <__libc_csu_fini>, rtld_fini=0x11e940 <_dl_fini>,
stack_end=0xbfdd7edc) at libc-start.c:220
#14 0x0804f671 in _start ()
(gdb) thread apply all bt

Thread 3 (Thread 0xb58feb90 (LWP 12633)):
#0  0x0012d402 in __kernel_vsyscall ()
#1  0x0752eac3 in __poll (fds=0x75b9ff4, nfds=2, timeout=-1) at
../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0309e583 in g_main_context_iterate (context=0xa20ca20, block=1,
dispatch=1, self=0xa206d98) at gmain.c:2996
#3  0x0309e8f9 in IA__g_main_loop_run (loop=0xa20a098) at gmain.c:2898
#4  0x028ac234 in libnm_glib_dbus_worker (user_data=0xa20cb28) at libnm_glib.c:427
#5  0x030be72f in g_thread_create_proxy (data=0xa206d98) at gthread.c:635
#6  0x003fa50b in start_thread (arg=0xb58feb90) at pthread_create.c:297
#7  0x07538b2e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb62ffb90 (LWP 17415)):
#0  0x0012d402 in __kernel_vsyscall ()
#1  0x003fe5d5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x0307dd82 in g_async_queue_pop_intern_unlocked (queue=0xadc64900,
try=<value optimized out>, end_time=0x0)
    at gasyncqueue.c:334
#3  0x005cefe5 in e_msgport_wait (msgport=0xa5d5100) at e-msgport.c:684
#4  0x0036c0ce in ep_msg_send (msg=0xae20ff00) at e-passwords.c:298
#5  0x0036dc35 in e_passwords_get_password (component_name=0x526eebe "Mail", 
    key=0xb2c51aa0 "pop://kmaraas@mail.broadpark.no/") at e-passwords.c:1121
#6  0x052401bb in get_password (session=0x9f24cf0, service=0xb24f4f0,
domain=0x526eebe "Mail", 
    prompt=0xae2d5a00 "Vennligst oppgi POP-passord for kmaraas på vert
mail.broadpark.no", item=0x4c4d545 "password", 
    flags=4, ex=0xa503b04) at mail-session.c:184
#7  0x0032d5b5 in camel_session_get_password (session=0x9f24cf0,
service=0xb24f4f0, domain=0x0, 
    prompt=0xae2d5a00 "Vennligst oppgi POP-passord for kmaraas på vert
mail.broadpark.no", item=0x4c4d545 "password", 
    flags=4, ex=0xa503b04) at camel-session.c:376
#8  0x04c4c7a0 in pop3_try_authenticate (service=0xb24f4f0, reprompt=<value
optimized out>, errmsg=<value optimized out>, 
    ex=0xa503b04) at camel-pop3-store.c:479
#9  0x04c4ccf9 in pop3_connect (service=0xb24f4f0, ex=0xa503b04) at
camel-pop3-store.c:601
#10 0x0032c3af in camel_service_connect (service=0xb24f4f0, ex=0xa503b04) at
camel-service.c:371
---Type <return> to continue, or q <return> to quit---
#11 0x0032d7c2 in camel_session_get_service_connected (session=0x9f24cf0, 
    url_string=0xa3c3aa8 "pop://kmaraas@mail.broadpark.no/;use_ssl=never",
type=CAMEL_PROVIDER_STORE, ex=0xa503b04)
    at camel-session.c:271
#12 0x052421d2 in mail_tool_get_inbox (url=0xa3c3aa8
"pop://kmaraas@mail.broadpark.no/;use_ssl=never", ex=0xa503b04)
    at mail-tools.c:70
#13 0x0523c736 in fetch_mail_exec (m=0xa503af0) at mail-ops.c:296
#14 0x05238239 in mail_msg_proxy (msg=0xa503af0) at mail-mt.c:500
#15 0x030c02b8 in g_thread_pool_thread_proxy (data=0xa23ac10) at gthreadpool.c:265
#16 0x030be72f in g_thread_create_proxy (data=0xa8c4a28) at gthread.c:635
#17 0x003fa50b in start_thread (arg=0xb62ffb90) at pthread_create.c:297
#18 0x07538b2e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7f90710 (LWP 12622)):
#0  0x0012d402 in __kernel_vsyscall ()
#1  0x0040152b in read () from /lib/libpthread.so.0
#2  0x0120afd0 in read_all (fd=35, buf=0xb2dd03a8 "", len=4) at
/usr/include/bits/unistd.h:45
#3  0x0120c398 in run_sync_operation (buffer=0xbfdd7ab4,
receive_buffer=0xbfdd7aa0) at gnome-keyring.c:652
#4  0x0120c80e in gnome_keyring_find_items_sync
(type=GNOME_KEYRING_ITEM_NETWORK_PASSWORD, attributes=0xada51cb0, 
    found=0xbfdd7b38) at gnome-keyring.c:2148
#5  0x0036c466 in ep_get_password (msg=0xae20ff00) at e-passwords.c:702
#6  0x0036bfc5 in ep_idle_dispatch (data=0x0) at e-passwords.c:237
#7  0x03099541 in g_idle_dispatch (source=0xb2c4ee00, callback=0x4,
user_data=0x0) at gmain.c:4132
#8  0x0309b10c in IA__g_main_context_dispatch (context=0x9ec94c8) at gmain.c:2061
#9  0x0309e54f in g_main_context_iterate (context=0x9ec94c8, block=1,
dispatch=1, self=0x9ea26c8) at gmain.c:2694
#10 0x0309e8f9 in IA__g_main_loop_run (loop=0x9ef0b50) at gmain.c:2898
#11 0x00898813 in bonobo_main () at bonobo-main.c:311
#12 0x0805e6f1 in main (argc=2, argv=0xbfdd7ee4) at main.c:602
#13 0x0747b390 in __libc_start_main (main=0x805e340 <main>, argc=2,
ubp_av=0xbfdd7ee4, init=0x805eee0 <__libc_csu_init>, 
    fini=0x805eed0 <__libc_csu_fini>, rtld_fini=0x11e940 <_dl_fini>,
stack_end=0xbfdd7edc) at libc-start.c:220
#14 0x0804f671 in _start ()
Comment 2 Matthew Barnes 2007-12-11 16:07:58 EST
Hmm, my initial suspicion is gnome-keyring.  I don't think Evolution has really
changed its keyring logic much recently.  I'll try to investigate further if it
happens to me.
Comment 3 sangu 2007-12-11 18:44:13 EST
This problem doesn't happens in gnome-keyrings-2.20.2-2.fc9 ( See also bug 416991 )
Comment 4 Kjartan Maraas 2007-12-12 11:08:28 EST
I can confirm that it goes away here too if I go back to the version mentioned
above.
Comment 5 Matthew Barnes 2007-12-21 12:18:41 EST

*** This bug has been marked as a duplicate of 416991 ***

Note You need to log in before you can comment on or make changes to this bug.