Bug 418981 - u+0123, latin small letter g with cedilla isn't processed
u+0123, latin small letter g with cedilla isn't processed
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: tetex-unicode (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 18:12 EST by Einars Lielmanis
Modified: 2013-12-30 09:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 00:39:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Einars Lielmanis 2007-12-10 18:12:29 EST
Description of problem:

u+0123, latin small letter g with cedilla isn't processed by utf8x.


Version-Release number of selected component (if applicable):


How reproducible:

Try to process the following latex document:

\documentclass[a4paper,10pt]{article}
\usepackage[utf8x]{inputenc}
\begin{document}
\section{Latvian alphabet}
aābcčdeēfgģhiījkķlļmnņoprsštuūvzž
AĀBCČDEĒFGĢHIĪJKĶLĻMNŅOPRSŠTUŪVZŽ
\end{document}

Steps to Reproduce:
1. make a file test.ltx with the specified contents
2. latex test.ltx
  
Actual results:

./test.ltx:8:Package ucs Error: Unknown Unicode character 291 = U+0123,(ucs)
possibly declared in uni-1.def. aābcčdeēfgģ

Expected results:

proper dvi/pdf file generated.

Additional info:

What's surprising, is, only the small g is affected, not the captial one. Of
course, \v{g} can be used instead, if inconvenient.
Comment 1 Aurelien Bompard 2007-12-11 00:39:20 EST
Thanks for filing this bug, but you'd be better off reporting this upstream,
since there is very little chance this has anything to do with the Fedora packaging.
Thanks.
Comment 2 Evalds Urtans 2013-12-30 09:12:34 EST
This problem still exists using MiKTeX 2.9 to resolve it

C:\Users\[User]\AppData\Roaming\MiKTeX\2.9\tex\latex\ucs\uni-1.def

Change line:
\uc@dclc{291}{dirty}{\leavevmode\vbox{\baselineskip\z@skip\ialign{\hss##\hss\crcr\vbox to.65ex{\hbox{\char"60}\vss}\crcr g\crcr}}}%

to

\uc@dclc{291}{default}{\v g}%

Note You need to log in before you can comment on or make changes to this bug.